Mailinglist Archive: opensuse-support (91 mails)

< Previous Next >
[opensuse-support] wifi and eth wicked same network should fallback - bond?
Hi,

i try the whole day to get a laptop tumbleweed kde, xwindows, wicked
running with wifi and cable lan, static ipv4 only.
network is 192.168.0.x
cable: enp3s0 should be 192.168.0.23
wifi: wlp2s0 should be 192.168.0.43 (driver is iwlwifi)

most of time this laptop is connected to the eth0
sometimes if it is not connected, it should use wifi
to go into the same network (and to go only in this network).

so i decided to configure both networks inside yast

i get it running with cable, and i get it running with
wifi, BUT if i activate both together inside yast,
it will mess up.
the reason seems to be the routing.
if i do NOT assign enp3s0 or wlp2s0 "-" inside yast,
ip ro
will show no routing at all.
if insert one of them, it will partly work as long as this
connection is ok.

i tried to add a second routing with:

ip route delete default
ip route add default via 192.168.0.99 metric 101 dev wlp2s0
ip route add default via 192.168.0.99 metric 102 dev enp3s0

but still the same problem.

then i was thinking try to bond both networkadapters together:
in yast i made a bond0
gave theme the address 192.168.0.23 and put both network adapters
to the bond0 (removed the ip addresses and they jump to "activate by hotplugged"
and made standartroute to bond0

as soon as i say ok in yast it takes some seconds to write the configuration,
and after this (if before both adapters where visible inside the network)
the wifi adapter will switched off, never seen by
ip ro
(and of course also not inside the net)
i checked also:
rfkill list
(to make shure its not blocked) all are on "no"
inside
/etc/sysconfig/network/ifcfg-bon0
both slaves are inside,
and the ifcfg-wlp2s0 file only differs from standalone
to the bond version in
BOOTPROTO
and
STARTMODE
and as i have read inside internet, thats correct.

could anybody help me to get it running like:
fallback from one to the other network adapters,
normally using enp3s0 if not present using wlp2s0

i do not take care how to get to this.
i have had it running with opensuse 42.2? i think
was before on that laptop. as i remember there
it was networkmanager. but if i now switch inside yast to
networkmanager, i have no possibility to
change anything inside yast at enp3s0 or bond0 or wlp2s0
and network is not present at all.

simoN



--
www.becherer.de

--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups