Mailinglist Archive: opensuse-support (159 mails)

< Previous Next >
Re: [opensuse-support] creating qemu VM with --boot uefi fails due to missing AppArmor profile
  • From: "Knurpht @ openSUSE" <knurpht@xxxxxxxxxxxx>
  • Date: Fri, 01 Jun 2018 12:41:58 +0200
  • Message-id: <2615772.RIy9uyUlsq@knurpht-hp>
Op vrijdag 1 juni 2018 12:37:03 CEST schreef Christian Neyers:
Hello list,

I have a problem creating virtual machines with UEFI boot mode. It seems
that the required AppArmor profile is not created.

% virt-install --connect qemu:///system --boot uefi --name ovmf --memory
1024 --disk size=10
WARNING No operating system detected, VM performance may suffer. Specify an
OS with --os-variant for optimal results.

Starting install...
Allocating 'ovmf-1.qcow2'

| 10 GB 00:00:00

ERROR internal error: cannot load AppArmor profile
'libvirt-071236ef-5b3d-457e-962b-bfedda1bbba5'
...

Looking for the profile yields no result:

% find /etc/apparmor.d/libvirt/ -name
libvirt-071236ef-5b3d-457e-962b-bfedda1bbba5

Though when I create a non-UEFI VM, it works as expected.

% virt-install --connect qemu:///system --boot hd --name ovmf --memory 1024
--disk size=10
% virsh --connect qemu:///system dominfo ovmf | grep label
Security label: libvirt-76ae48ba-fa95-4695-8bfc-f461d1cab1c0 (enforcing)
% find /etc/apparmor.d/libvirt/ -name 76ae48ba-fa95-4695-8bfc-f461d1cab1c0
/etc/apparmor.d/libvirt/libvirt-76ae48ba-fa95-4695-8bfc-f461d1cab1c0

Is there something I'm missing or should I file a bug?

Cheers
Two options:
Wait for cboltz to jump in ( our Apparmor hero )
Try setting it up through virt-manager, then have a look at the config and see
if there's any difference with what you're trying from cli.

--
Gertjan Lettink a.k.a. Knurpht
openSUSE Board Member
openSUSE Forums Team


--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
References