Mailinglist Archive: opensuse-security (16 mails)

< Previous Next >
Re: [opensuse-security] 12.3 update-non-oss outdated?
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Wed, 14 Aug 2013 14:35:32 +0200 (CEST)
  • Message-id: <alpine.LNX.2.00.1308141426590.305@minas-tirith.valinor>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256



El 2013-08-14 a las 13:42 +0200, Marcus Meissner escribió:

It would be nice to be able to disable the warning, be it locally or on the
server.

It is a necessary precaution for when you really use an outdated mirror
or a mirror that is blocking updates for you.

Yes, I know. But when the system was designed the update repo always changed periodically, it would never be frozen. The situation is different now: there is the non-oss repo, that seldom changes, and there is evergreen, that has a frozen update repo plus an additional new update repo.

Thus now we need some kind of override. For evergreen, a manual override, perhaps a flag file that is downloaded as an update from the evergreen repo. For non-oss, just a longer override, perhaps, or dummy updates.

That's up to you devs and packagers to design ;-)

Usability adjustments might however be necessary if users react the wrong way.

True.

- -- Cheers
Carlos E. R.

(from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)

iF4EAREIAAYFAlILeZQACgkQja8UbcUWM1yftgEAoBWxHq75PIA/wPy7/NBCGqpW
tJchLIjeeD4jeEfVOP4A/02VqR6fGKIxm3A/5QRt1GG55DqSny/asMFFSXux82dN
=4GNH
-----END PGP SIGNATURE-----
< Previous Next >