Mailinglist Archive: opensuse-security (30 mails)

< Previous Next >
Re: [opensuse-security] java-1_6_0-openjdk update fails - 11.0 x64
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Tue, 10 Mar 2009 22:01:46 +0100
  • Message-id: <20090310210146.GA24857@xxxxxxx>
On Tue, Mar 10, 2009 at 09:57:41PM +0100, David Huecking wrote:
Am Monday 09 March 2009 21:01:09 schrieb Eoin Kirwan:
[...]
With zypper:

# zypper lu
Reading installed packages...
Patches

Repository | Name | Version | Category | Status
----------------------+--------------------+---------+----------+-------
openSUSE-11.0-Updates | java-1_6_0-openjdk | 578 | security | Needed
# zypper up
Reading installed packages...

Problem: Solvable java-1_6_0-openjdk-1.4_b14-24.2.i586 conflicts with
tzdata-java provided by itself
Solution 1: Following actions will be done:
deinstallation of java-1_6_0-openjdk-plugin-1.2_b09-9.1.i586
deinstallation of java-1_6_0-openjdk-1.2_b09-9.1.i586
Solution 2: do not install patch:java-1_6_0-openjdk-578.noarch

Choose from above solutions by number or cancel [1/2/C]:


- I chose cancel. Has anyone else found this problem?
As the problem appears to be with the update itself, will there be an
updated update? :)

Hi Eoin,

just got nearly the same problem...
--- 8< ---
Problem: Solvable java-1_6_0-openjdk-1.4_b14-24.2.i586 conflicts with
tzdata-java provided by itself
Solution 1: Following actions will be done:
deinstallation of java-1_6_0-openjdk-devel-1.2_b09-9.1.i586
deinstallation of java-1_6_0-openjdk-1.2_b09-9.1.i586
Solution 2: do not install patch:java-1_6_0-openjdk-578.noarch

Choose from above solutions by number or cancel [1/2/C]: ^C
--- 8< ---
So what's wrong here?

It needs timezone-java from the OSS repo... briefly add/enable the OSS
repo then the update should go through.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-security+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security+help@xxxxxxxxxxxx

< Previous Next >