Mailinglist Archive: opensuse-security (32 mails)

< Previous Next >
[opensuse-security] 'failed' msg in /var/log/boot.msg when encrypted swap set to use "empty password"?
  • From: PGNet <pgnet.trash+ossec@xxxxxxxxx>
  • Date: Wed, 14 Jan 2009 11:03:58 -0800
  • Message-id: <dbd51810901141103y5c7b54eak68f4f2df158d9a27@xxxxxxxxxxxxxx>
I've setup an encrypted SWAP partition on a RAID-1 array.

In /etc/fstab, I've,

/dev/mapper/cr_md1 swap swap defaults 0 0

@ SWAP encryption setup, I selected "empty password", assuming that's
the equivalent of using random/variable passwords.

system boots OK, but i note in /var/log/boot.msg

egrep "md1|swap" /var/log/boot.msg
<6>Command line: root=/dev/system/ROOT resume=/dev/md1 ...
<5>Kernel command line: root=/dev/system/ROOT resume=/dev/md1 ...
<6>md: md1 stopped.
<6>raid1: raid set md1 active with 2 out of 2 mirrors
<6>md1: bitmap initialized from disk: read 1/1 pages, set 0 bits
<6>created bitmap (8 pages) for device md1
Trying manual resume from /dev/md1
Invoking userspace resume from /dev/md1
Trying manual resume from /dev/md1
Invoking in-kernel resume from /dev/md1
doneActivating swap-devices in /etc/fstab...
---> donePlease enter passphrase for /dev/md1 (cr_md1): /dev/md1... failed
doneActivating remaining swap-devices in /etc/fstab...

is that,

"Please enter passphrase for /dev/md1 (cr_md1): /dev/md1... failed"

a problem? I'm unclear, as I've noticed nothing else relevant in any logs :-/

How can I specifically validate that encryption on the swap partition
if functioning correctly?

Thanks.
--
To unsubscribe, e-mail: opensuse-security+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups