Mailinglist Archive: opensuse-security (138 mails)

< Previous Next >
Re: [suse-security] Problem with latest Opera update
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Thu, 1 Dec 2005 08:56:26 +0100
  • Message-id: <20051201075626.GA4697@xxxxxxx>
On Thu, Dec 01, 2005 at 07:49:17AM +0000, Armin Schoech wrote:
> Hi,
>
> when I try to install the latest Opera update for SuSE 9.1
> "opera-8.51-2.1.i586.patch.rpm" I get the following error message:
>
> ************************
> * ERROR: Update failed *
> ************************
>
> error: Failed dependencies:
> libstdc++.so.6 is needed by opera-8.51-2.1
> libstdc++.so.6(CXXABI_1.3) is needed by opera-8.51-2.1
> libstdc++.so.6(GLIBCXX_3.4) is needed by opera-8.51-2.1
>
>
> I have the latest "libstdc++" for SuSE 9.1 installed:
>
> host:~ # rpm -q libstdc++
> libstdc++-3.3.3-41
> host:~ # rpm -ql libstdc++
> /usr/lib/libstdc++.so.5
> /usr/lib/libstdc++.so.5.0.5
> /usr/share/locale/de/LC_MESSAGES/libstdc++.mo
> /usr/share/locale/fr/LC_MESSAGES/libstdc++.mo
> pcschoe:~ #
>
>
> Can anyone confirm this problem ?

Sigh. I only tested the update on 10.0 before releasing, considering
it just a minor update.

I was not aware that they bumped their libstdc++ version requirement
in this minor release.

We will investigate.

Ciao, Marcus

< Previous Next >
List Navigation
Follow Ups
References