Mailinglist Archive: opensuse-security (232 mails)

< Previous Next >
RE: [suse-security] Susefirewall2 weblogger
  • From: "Markus Heidinger" <suselist@xxxxxxxxxxxxxx>
  • Date: Tue, 4 Oct 2005 00:32:31 +0200
  • Message-id: <!&!AAAAAAAAAAAYAAAAAAAAAP9QkKQ4AexDn8E0JJeMbqnCgAAAEAAAAFWkFiAb0/VNjAy0so17lrgBAAAAAA==@xxxxxxxxxxxxxx>
Bruno Cochofel wrote at Tuesday, October 04, 2005 12:09 AM

> Thanks for all...
> Now my problem... I'm not that good with perl, so how can I install
> session support and DBI on Perl? I think I've got this right, there's
> nothing to do with mysql, right? Only the support for perl...

IIRC you need the packages "perl-DBI" and "php4-mysql", the latter obviously
has to do with PHP, not Perl ;-) ... Install all packages required the two
packages mentioned. For Apache, you will need "apache(2)-mod_php4", and
maybe, but I am really not sure at the moment, "apache(2)-mod_perl".
As you can see, I installed php4 since the web log analyzer is rather old
(of 2002). Not sure it would work with php5 as well.

Just as a hint: since a mysql database as well as a webserver should not run
on the same machine as the firewall, i installed them on a different
machine, just the feeder script is running at the firewall machine. This
works fine as well.

HTH
Regards,
Markus




< Previous Next >
References