Mailinglist Archive: opensuse-security (485 mails)

< Previous Next >
MPPE/pppd
  • From: Henrik Löwendahl-Nyrén <henrik.lowendahl-nyren@xxxxxxxxx>
  • Date: Fri, 05 Mar 2004 07:14:06 +0100
  • Message-id: <1078467245.2210.18.camel@xxxxxxxxxxxxxxxxxxxx>
Hi!

I'm running SuSE 9.0 with the k_deflt-2.4.21-192 kernel and pppd version
2.4.2 and the following mppe-support:
# modinfo ppp_mppe
filename:
/lib/modules/2.4.21-192-default/kernel/drivers/net/ppp_mppe.o
description: <none>
author: <none>
license: "Dual BSD/GPL"

The problem is that pppd 2.4.2 and mppe 2.4.0 has compability issues -
the mppe-options are different. This describes the problem:
http://pptpclient.sourceforge.net/howto-diagnosis.phtml#mppe_rbkhns
And here are the options for the different versions:
http://pptpclient.sourceforge.net/howto-diagnosis.phtml#pppd_options

One way to solve it is to use an older version of pppd, I guess, but
that doesn't sound as the best solution.


Is there a way to get mppe 2.4.2-support in the Suse kernel, without
having to recompile it manually?
If possible I'd like to keep my system as "rpm-clean" as possible, if
you know what I mean... ;)
But if the only way to get mppe 2.4.2-support is to recompile the
kernel, I guess I'll just have to do that...

Thanks in advance!

/Henrik L-N
--
________________________________________________

Henrik Löwendahl-Nyrén, Systems Engineer, Student IT
Karolinska Institutet, University Library
Alfred Nobels allé 8:100, SE 141 83 Huddinge
Mobile: +46 702 80 70 43
Telephone: +46 8 524 84 137
Fax: +46 8 524 84 310
Web: http://kib.ki.se - http://studentit.ki.se
________________________________________________

< Previous Next >
This Thread
  • No further messages