Mailinglist Archive: opensuse-security (394 mails)

< Previous Next >
VNC through SSH tunnelling problem
  • From: Neil Anderson <cleidh_mor@xxxxxxxxxxxxxxx>
  • Date: Tue, 9 Dec 2003 20:46:08 +0000
  • Message-id: <200312092047.11808.cleidh_mor@xxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi List,

Apologies if this is off-topic... please feel free to redirect me!

I'm having a problem tunelling through SSH from my Windoze machine at work to
my Linux machine at home. My work machine is a laptop, so I tested the whole
thing at home without any problems. I.e. the laptop can connect to my SuSE
8.2 desktop using port forwarding with no probs at all. I use PuTTY on the
Windoze machine to SSH to the Linux box, start a VNC server, then connect VNC
Viewer on Windows to the localhost.

When I try it from work, I SSH to my Linux box ok, start a VNC server ok and
can do a "straight" VNC into the linux box. However, if I try to use the VNC
viewer to set up a connection to localhost on the Windoze machine (to use
port forwarding) nothing happens and if I look in PuTTY's event log it has
the error "server refused forwarded connection".

Now, I have tried numerous things to get this to work. It can't be the
firewall, as I have tried doing this with the firewall stopped and have
checked the work firewall and can see the connection going through. I am
fairly sure it's not SSH as I ran sshd -de and saw an error "channel1
connection refused" when I tried to use the port forwarding. I have also
tried running VNC server with the --localhost option set but still no joy.
SO, I'm left totally stumped. I'm using sshd and vncserver on my linux box,
straight from the SuSE 8.2 build (unless they've been auto-updated by YOU).
The only thing I can think of is that VNC server is refusing loopback
connections from sshd, but then why does it work if I do it at home, when the
laptop is on the local subnet?!

Anybody got any ideas?

Thanks for any advice,
Cheers,
Neil
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2-rc1-SuSE (GNU/Linux)

iD8DBQE/1jSQ2h6w8BNEwKYRAvQDAJ9il2lB3oOxcQTzQ8m9cla9GNU1rACcC97S
pl/eRDFS2DeTfL/9Q48Lr+E=
=n0RV
-----END PGP SIGNATURE-----


< Previous Next >
Follow Ups