Mailinglist Archive: opensuse-security (359 mails)

< Previous Next >
Re: mppe pptp patch - was: Problem with freeswan after 2.4.19 kernel update
Hi,

>Thanks :) have since had a look at the SuSE support pages
>(http://www.suse.de/en/private/download/updates/81_i386.html) and ...

I fixed this just after the kernel update myself, so I ignored this one :-(

>... so I guess, either revert to the old kernel or better still, update
>the freeswan packages - will post back if the latter approach works.

It works, for clients using ipsec only, so an automatic update via yast will
fix ipsec.
My problem was that the included mppe-patch did not work in a setup with
pptpd and freeswan.
I'm using VPN on a dsl router for both linux and windows clients, so I
decided pptp has to be offered too.
The mppe kernel patch was applied in the stock kernel, but did not work
well. I don't know if this one is fixed yet.
When using XP clients your received error messages about the packet size
when using the connection for large transfers, terminating the pptp session.
There must have been some other patch disabling the fix, so I decided to
compile a new kernel myself...

regards,

Dieter

---------------------------------------------------------------
Dieter Kirchner
Systemadministration BUPNET
+49 551 54707 62 D-Goettingen
http://www.bupnet.de
---------------------------------------------------------------


< Previous Next >
References