Mailinglist Archive: opensuse-security (320 mails)

< Previous Next >
Re: [suse-security] Can't make losetup mount a crypto file to the loopback device (SuSE 8.2)
  • From: Adam Daniel <adamd@xxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 1 May 2003 13:41:50 +1000
  • Message-id: <20030501034150.GD30976@xxxxxxxxxx>
I had this same problem and the solution was rather simple, the module for twofish wasnt loaded.

do a lsmod and look for:

loop_fish2 9120 0

If its not there, then do a insmod loop_fish2 and it all should work.

Adam



On Wed, Apr 30, 2003 at 11:51:25PM +0200, Bo Jacobsen wrote:
> I'm trying to mount a file to the loopback device but the losetup command
> complains about it.
>
> I'm using the command line:
> losetup -e twofish /dev/loop0 /root/testfile
>
> losetup asks for a password but returns:
> ioctl: LOOP_SET_STATUS: invalid argument
> when one is entered
>
>
> "losetup -e none" works
>
> I have tried with the standard kernel in SuSE 8.2 but also kernel 2.4.20-13 with both
> "loopback device support" and "Twofish encryption for loopback device" compiled
> into the kernel.
>
>
> Any suggestions.
>
> Thanks in advance
> Bo Jacobsen
>

--


Technical Consultant
-----------------------------------------------------------------------
FORENSIC DATA SERVICES PTY LIMITED
http://www.forensicdata.com.au
------------------------------------------------------------------------
The information contained in this e-mail is confidential and is
intended solely for the addressee. If you received this e-mail by
mistake please notify us immediately and delete all copies of this
message. You must not disclose or use in any way the information in the
e-mail. It is the responsibility of the recipient to virus scan this
e-mail and any attachments included.

< Previous Next >
List Navigation