Mailinglist Archive: opensuse-security (636 mails)

< Previous Next >
Re: [suse-security] updating bind8
  • From: Muckl <muckl@xxxxxxxxxxxxx>
  • Date: Thu, 1 Feb 2001 16:33:22 +0100 (MET)
  • Message-id: <Pine.LNX.4.31.0102011626360.29450-100000@xxxxxxxxxxxxxxxxxxxxx>
Hello,

On Thu, 1 Feb 2001, Roman Drahtmueller wrote:

> > during checking the installation of bindutil with rpm,
> > i was told that there are a lot of conflicts with my old,
> > non-binutil-using bind8.1.x.x.
> > now what is the most elegant way of updating? uninstall the
> > old bind8.1.x.x (saving conf's etc) or forcing the rpm-
> > command?
>
> cd /
> tar cfvv /root/nameserver.tar etc/named.conf var/named
>
> rpm -e bind8 # while the nameserver is running... doesn't matter.
> rpm -Uhv bind8.rpm # may be necessary to force these commands
> rpm -ihv bindutil.rpm # using --force and --nodeps
>
> and finally
>
> tar xfvvp /root/nameserver.tar
>
> and `rcnamed restart´ to make the changes effective.

And maybe (like Daniel and me have to do) edit your master zonefiles.
This bind8 package seems to be restricter in syntax-checking.

After changing the first two lines in each zonefile from:

@ IN SOA ns.example.org. hostmaster.example.org.
(
to:

$TTL 1D
@ IN SOA ns.example.org. hostmaster.example.org. (

(the "(" has to be in the SOA line) bind accepted my zonefiles without
errors.

> > daniel
>
> Thanks,
> Roman.

cheers
Michael
--
Michael Röhrkasten http://www.behrensoft.de
Fingerprint: D4F5 5F01 4EDA 8F4F ED81 1EFE 0D63 E06C CD64 FB5E


< Previous Next >
References