Mailinglist Archive: opensuse-security (260 mails)

< Previous Next >
Apache & mod_SSL
  • From: Eric CHAPMAN <erch0000@xxxxxxxxxxxxxx>
  • Date: Thu, 13 Jul 2000 20:58:54 +0200
  • Message-id: <396E116E.C0C25DA4@xxxxxxxxxxxxxx>
Hi guys,

I am running a SuSE 6.4 box with Apache1.3.12 / OpenSSL/0.9.5...
I want to set up several virtual name based hosts, one with ssl and the
others without. I've tried several different httpd.conf setups, but
somehow
this does not want to work out. Right now my httpd.conf goes somewhat
like this:

[...]
<IfDefine SSL>
Listen 80
Listen 443
</IfDefine>
[...]
NameVirtualHost 123.456.78.9:80
NameVirtualHost 123.456.78.9:443

<VirtualHost my1st.host.org:80>
SSLDisable
ServerName my1st.host.org
ServerAdmin eric@xxxxxxxx
DocumentRoot /usr/local/httpd/htdocs1
</VirtualHost>

<VirtualHost my2nd.host.org:443>
SSLEnable
ServerName my2nd.host.org
ServerAdmin eric@xxxxxxxx
DocumentRoot /usr/local/httpd/htdocs2
SSLCertificateFile /etc/httpd/ssl.crt/host.org.cert
SSLCertificateKeyFile /etc/httpd/ssl.key/host.org.key
</VirtualHost>
[...more VirtualHost:80...]

and ssl_engine_log shows:
[13/Jul/2000 23:38:24 28689] [info] Init: Reinitializing OpenSSL
library
[13/Jul/2000 23:38:24 28689] [info] Init: Seeding PRNG with 136 bytes
of entropy
[13/Jul/2000 23:38:24 28689] [info] Init: Configuring temporary RSA
private keys (512/1024 bits)
[13/Jul/2000 23:38:24 28689] [info] Init: Configuring temporary DH
parameters (512/1024 bits)
[13/Jul/2000 23:38:24 28689] [info] Init: Initializing (virtual)
servers for SSL
[13/Jul/2000 23:38:24 28689] [warn] Init: (my2nd.host.org:443) You
configured HTTP(80) on the standard HTTPS(443) port!

Before the Virtualhost entries all looked like this: <VirtualHost
123.456.78.9:80>
then I got the 'You configured HTTP(80) on the standard HTTPS(443)
port!' for every
Virtualhost. The server will not load unless I comment out the 443 Host.
The Apache and
mod_ssl online documents have not been very conclusive so far...

1. What is the difference between <VirtualHost 123.456.78.9>,
<VirtualHost 123.456.78.9:80>
and <VirtualHost my.host.org:80>?
2. Ionly have one IP address on the box, but could add another. Could
this resolve the
port prblem?
If anyone knows his way with mod_ssl and Virtualhost, I'd be glad for
any help


THX, eric


< Previous Next >
Follow Ups