Mailinglist Archive: opensuse-security-announce (82 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1680-1: important: Security update for libproxy
openSUSE Security Update: Security update for libproxy
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1680-1
Rating: important
References: #1176410 #1177143
Cross-References: CVE-2020-25219 CVE-2020-26154
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libproxy fixes the following issues:

- CVE-2020-25219: Rewrote url::recvline to be nonrecursive (bsc#1176410).
- CVE-2020-26154: Fixed a buffer overflow when PAC is enabled
(bsc#1177143).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1680=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

libproxy-debugsource-0.4.15-lp152.5.3.1
libproxy-devel-0.4.15-lp152.5.3.1
libproxy-tools-0.4.15-lp152.5.3.1
libproxy-tools-debuginfo-0.4.15-lp152.5.3.1
libproxy1-0.4.15-lp152.5.3.1
libproxy1-debuginfo-0.4.15-lp152.5.3.1

- openSUSE Leap 15.2 (noarch):

python-libproxy-0.4.15-lp152.5.3.1
python3-libproxy-0.4.15-lp152.5.3.1

- openSUSE Leap 15.2 (x86_64):

libproxy-plugins-debugsource-0.4.15-lp152.5.3.1
libproxy-sharp-0.4.15-lp152.5.3.1
libproxy1-32bit-0.4.15-lp152.5.3.1
libproxy1-32bit-debuginfo-0.4.15-lp152.5.3.1
libproxy1-config-gnome3-0.4.15-lp152.5.3.1
libproxy1-config-gnome3-debuginfo-0.4.15-lp152.5.3.1
libproxy1-config-kde-0.4.15-lp152.5.3.1
libproxy1-config-kde-debuginfo-0.4.15-lp152.5.3.1
libproxy1-networkmanager-0.4.15-lp152.5.3.1
libproxy1-networkmanager-debuginfo-0.4.15-lp152.5.3.1
libproxy1-pacrunner-webkit-0.4.15-lp152.5.3.1
libproxy1-pacrunner-webkit-debuginfo-0.4.15-lp152.5.3.1
perl-Net-Libproxy-0.4.15-lp152.5.3.1
perl-Net-Libproxy-debuginfo-0.4.15-lp152.5.3.1


References:

https://www.suse.com/security/cve/CVE-2020-25219.html
https://www.suse.com/security/cve/CVE-2020-26154.html
https://bugzilla.suse.com/1176410
https://bugzilla.suse.com/1177143

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages