Mailinglist Archive: opensuse-security-announce (110 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1568-1: important: Security update for libqt5-qtbase
openSUSE Security Update: Security update for libqt5-qtbase
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1568-1
Rating: important
References: #1172515 #1176315
Cross-References: CVE-2020-17507
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for libqt5-qtbase fixes the following issues:

- CVE-2020-17507: Fixed a buffer overflow in XBM parser (bsc#1176315)
- Made handling of XDG_RUNTIME_DIR more secure (bsc#1172515)

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-1568=1



Package List:

- openSUSE Leap 15.1 (noarch):

libQt5Core-private-headers-devel-5.9.7-lp151.4.6.1
libQt5DBus-private-headers-devel-5.9.7-lp151.4.6.1
libQt5Gui-private-headers-devel-5.9.7-lp151.4.6.1
libQt5KmsSupport-private-headers-devel-5.9.7-lp151.4.6.1
libQt5Network-private-headers-devel-5.9.7-lp151.4.6.1
libQt5OpenGL-private-headers-devel-5.9.7-lp151.4.6.1
libQt5PlatformSupport-private-headers-devel-5.9.7-lp151.4.6.1
libQt5PrintSupport-private-headers-devel-5.9.7-lp151.4.6.1
libQt5Sql-private-headers-devel-5.9.7-lp151.4.6.1
libQt5Test-private-headers-devel-5.9.7-lp151.4.6.1
libQt5Widgets-private-headers-devel-5.9.7-lp151.4.6.1
libqt5-qtbase-private-headers-devel-5.9.7-lp151.4.6.1

- openSUSE Leap 15.1 (x86_64):

libQt5Bootstrap-devel-static-5.9.7-lp151.4.6.1
libQt5Concurrent-devel-5.9.7-lp151.4.6.1
libQt5Concurrent5-5.9.7-lp151.4.6.1
libQt5Concurrent5-debuginfo-5.9.7-lp151.4.6.1
libQt5Core-devel-5.9.7-lp151.4.6.1
libQt5Core5-5.9.7-lp151.4.6.1
libQt5Core5-debuginfo-5.9.7-lp151.4.6.1
libQt5DBus-devel-5.9.7-lp151.4.6.1
libQt5DBus-devel-debuginfo-5.9.7-lp151.4.6.1
libQt5DBus5-5.9.7-lp151.4.6.1
libQt5DBus5-debuginfo-5.9.7-lp151.4.6.1
libQt5Gui-devel-5.9.7-lp151.4.6.1
libQt5Gui5-5.9.7-lp151.4.6.1
libQt5Gui5-debuginfo-5.9.7-lp151.4.6.1
libQt5KmsSupport-devel-static-5.9.7-lp151.4.6.1
libQt5Network-devel-5.9.7-lp151.4.6.1
libQt5Network5-5.9.7-lp151.4.6.1
libQt5Network5-debuginfo-5.9.7-lp151.4.6.1
libQt5OpenGL-devel-5.9.7-lp151.4.6.1
libQt5OpenGL5-5.9.7-lp151.4.6.1
libQt5OpenGL5-debuginfo-5.9.7-lp151.4.6.1
libQt5OpenGLExtensions-devel-static-5.9.7-lp151.4.6.1
libQt5PlatformHeaders-devel-5.9.7-lp151.4.6.1
libQt5PlatformSupport-devel-static-5.9.7-lp151.4.6.1
libQt5PrintSupport-devel-5.9.7-lp151.4.6.1
libQt5PrintSupport5-5.9.7-lp151.4.6.1
libQt5PrintSupport5-debuginfo-5.9.7-lp151.4.6.1
libQt5Sql-devel-5.9.7-lp151.4.6.1
libQt5Sql5-5.9.7-lp151.4.6.1
libQt5Sql5-debuginfo-5.9.7-lp151.4.6.1
libQt5Sql5-mysql-5.9.7-lp151.4.6.1
libQt5Sql5-mysql-debuginfo-5.9.7-lp151.4.6.1
libQt5Sql5-postgresql-5.9.7-lp151.4.6.1
libQt5Sql5-postgresql-debuginfo-5.9.7-lp151.4.6.1
libQt5Sql5-sqlite-5.9.7-lp151.4.6.1
libQt5Sql5-sqlite-debuginfo-5.9.7-lp151.4.6.1
libQt5Sql5-unixODBC-5.9.7-lp151.4.6.1
libQt5Sql5-unixODBC-debuginfo-5.9.7-lp151.4.6.1
libQt5Test-devel-5.9.7-lp151.4.6.1
libQt5Test5-5.9.7-lp151.4.6.1
libQt5Test5-debuginfo-5.9.7-lp151.4.6.1
libQt5Widgets-devel-5.9.7-lp151.4.6.1
libQt5Widgets5-5.9.7-lp151.4.6.1
libQt5Widgets5-debuginfo-5.9.7-lp151.4.6.1
libQt5Xml-devel-5.9.7-lp151.4.6.1
libQt5Xml5-5.9.7-lp151.4.6.1
libQt5Xml5-debuginfo-5.9.7-lp151.4.6.1
libqt5-qtbase-common-devel-5.9.7-lp151.4.6.1
libqt5-qtbase-common-devel-debuginfo-5.9.7-lp151.4.6.1
libqt5-qtbase-debugsource-5.9.7-lp151.4.6.1
libqt5-qtbase-devel-5.9.7-lp151.4.6.1
libqt5-qtbase-examples-5.9.7-lp151.4.6.1
libqt5-qtbase-examples-debuginfo-5.9.7-lp151.4.6.1
libqt5-qtbase-platformtheme-gtk3-5.9.7-lp151.4.6.1
libqt5-qtbase-platformtheme-gtk3-debuginfo-5.9.7-lp151.4.6.1


References:

https://www.suse.com/security/cve/CVE-2020-17507.html
https://bugzilla.suse.com/1172515
https://bugzilla.suse.com/1176315

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages