Mailinglist Archive: opensuse-security-announce (110 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1483-1: important: Security update for perl-DBI
openSUSE Security Update: Security update for perl-DBI
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1483-1
Rating: important
References: #1176409 #1176412
Cross-References: CVE-2020-14392 CVE-2020-14393
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for perl-DBI fixes the following issues:

Security issues fixed:

- CVE-2020-14392: Memory corruption in XS functions when Perl stack is
reallocated (bsc#1176412).
- CVE-2020-14393: Fixed a buffer overflow on an overlong DBD class name
(bsc#1176409).

This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1483=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

perl-DBI-1.642-lp152.2.3.1
perl-DBI-debuginfo-1.642-lp152.2.3.1
perl-DBI-debugsource-1.642-lp152.2.3.1


References:

https://www.suse.com/security/cve/CVE-2020-14392.html
https://www.suse.com/security/cve/CVE-2020-14393.html
https://bugzilla.suse.com/1176409
https://bugzilla.suse.com/1176412

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages