Mailinglist Archive: opensuse-security-announce (110 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1459-1: moderate: Security update for openldap2
openSUSE Security Update: Security update for openldap2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1459-1
Rating: moderate
References: #1174154
Cross-References: CVE-2020-15719
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for openldap2 fixes the following issues:

- bsc#1174154 - CVE-2020-15719 - This resolves an issue with x509 SAN's
falling back to CN validation in violation of rfc6125.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1459=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

libldap-2_4-2-2.4.46-lp152.14.6.1
libldap-2_4-2-debuginfo-2.4.46-lp152.14.6.1
openldap2-2.4.46-lp152.14.6.1
openldap2-back-meta-2.4.46-lp152.14.6.1
openldap2-back-meta-debuginfo-2.4.46-lp152.14.6.1
openldap2-back-perl-2.4.46-lp152.14.6.1
openldap2-back-perl-debuginfo-2.4.46-lp152.14.6.1
openldap2-back-sock-2.4.46-lp152.14.6.1
openldap2-back-sock-debuginfo-2.4.46-lp152.14.6.1
openldap2-back-sql-2.4.46-lp152.14.6.1
openldap2-back-sql-debuginfo-2.4.46-lp152.14.6.1
openldap2-client-2.4.46-lp152.14.6.1
openldap2-client-debuginfo-2.4.46-lp152.14.6.1
openldap2-contrib-2.4.46-lp152.14.6.1
openldap2-contrib-debuginfo-2.4.46-lp152.14.6.1
openldap2-debuginfo-2.4.46-lp152.14.6.1
openldap2-debugsource-2.4.46-lp152.14.6.1
openldap2-devel-2.4.46-lp152.14.6.1
openldap2-devel-static-2.4.46-lp152.14.6.1
openldap2-ppolicy-check-password-1.2-lp152.14.6.1
openldap2-ppolicy-check-password-debuginfo-1.2-lp152.14.6.1

- openSUSE Leap 15.2 (x86_64):

libldap-2_4-2-32bit-2.4.46-lp152.14.6.1
libldap-2_4-2-32bit-debuginfo-2.4.46-lp152.14.6.1
openldap2-devel-32bit-2.4.46-lp152.14.6.1

- openSUSE Leap 15.2 (noarch):

libldap-data-2.4.46-lp152.14.6.1
openldap2-doc-2.4.46-lp152.14.6.1


References:

https://www.suse.com/security/cve/CVE-2020-15719.html
https://bugzilla.suse.com/1174154

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages