Mailinglist Archive: opensuse-security-announce (77 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1302-1: important: Security update for xorg-x11-server
openSUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1302-1
Rating: important
References: #1174633 #1174635 #1174638
Cross-References: CVE-2020-14345 CVE-2020-14346 CVE-2020-14347

Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for xorg-x11-server fixes the following issues:

- CVE-2020-14347: Leak of uninitialized heap memory from the X server to
clients on pixmap allocation (bsc#1174633, ZDI-CAN-11426).
- CVE-2020-14346: XIChangeHierarchy Integer Underflow Privilege Escalation
Vulnerability (bsc#1174638, ZDI-CAN-11429).
- CVE-2020-14345: XKB out-of-bounds access privilege escalation
vulnerability (bsc#1174635, ZDI-CAN-11428).

This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1302=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

xorg-x11-server-1.20.3-lp152.8.3.1
xorg-x11-server-debuginfo-1.20.3-lp152.8.3.1
xorg-x11-server-debugsource-1.20.3-lp152.8.3.1
xorg-x11-server-extra-1.20.3-lp152.8.3.1
xorg-x11-server-extra-debuginfo-1.20.3-lp152.8.3.1
xorg-x11-server-sdk-1.20.3-lp152.8.3.1
xorg-x11-server-source-1.20.3-lp152.8.3.1
xorg-x11-server-wayland-1.20.3-lp152.8.3.1
xorg-x11-server-wayland-debuginfo-1.20.3-lp152.8.3.1


References:

https://www.suse.com/security/cve/CVE-2020-14345.html
https://www.suse.com/security/cve/CVE-2020-14346.html
https://www.suse.com/security/cve/CVE-2020-14347.html
https://bugzilla.suse.com/1174633
https://bugzilla.suse.com/1174635
https://bugzilla.suse.com/1174638

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages