Mailinglist Archive: opensuse-security-announce (91 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:1064-1: important: Security update for webkit2gtk3
openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1064-1
Rating: important
References: #1173998
Cross-References: CVE-2020-13753 CVE-2020-9802 CVE-2020-9803
CVE-2020-9805 CVE-2020-9806 CVE-2020-9807
CVE-2020-9843 CVE-2020-9850
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available.

Description:

This update for webkit2gtk3 fixes the following issues:

- Update to version 2.28.3 (bsc#1173998):
+ Enable kinetic scrolling with async scrolling.
+ Fix web process hangs on large GitHub pages.
+ Bubblewrap sandbox should not attempt to bind empty paths.
+ Fix threading issues in the media player.
+ Fix several crashes and rendering issues.
+ Security fixes: CVE-2020-9802, CVE-2020-9803, CVE-2020-9805,
CVE-2020-9806, CVE-2020-9807, CVE-2020-9843, CVE-2020-9850,
CVE-2020-13753.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-1064=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libjavascriptcoregtk-4_0-18-2.28.3-lp151.2.21.1
libjavascriptcoregtk-4_0-18-debuginfo-2.28.3-lp151.2.21.1
libwebkit2gtk-4_0-37-2.28.3-lp151.2.21.1
libwebkit2gtk-4_0-37-debuginfo-2.28.3-lp151.2.21.1
typelib-1_0-JavaScriptCore-4_0-2.28.3-lp151.2.21.1
typelib-1_0-WebKit2-4_0-2.28.3-lp151.2.21.1
typelib-1_0-WebKit2WebExtension-4_0-2.28.3-lp151.2.21.1
webkit-jsc-4-2.28.3-lp151.2.21.1
webkit-jsc-4-debuginfo-2.28.3-lp151.2.21.1
webkit2gtk-4_0-injected-bundles-2.28.3-lp151.2.21.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.28.3-lp151.2.21.1
webkit2gtk3-debugsource-2.28.3-lp151.2.21.1
webkit2gtk3-devel-2.28.3-lp151.2.21.1
webkit2gtk3-minibrowser-2.28.3-lp151.2.21.1
webkit2gtk3-minibrowser-debuginfo-2.28.3-lp151.2.21.1

- openSUSE Leap 15.1 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.28.3-lp151.2.21.1
libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.28.3-lp151.2.21.1
libwebkit2gtk-4_0-37-32bit-2.28.3-lp151.2.21.1
libwebkit2gtk-4_0-37-32bit-debuginfo-2.28.3-lp151.2.21.1

- openSUSE Leap 15.1 (noarch):

libwebkit2gtk3-lang-2.28.3-lp151.2.21.1


References:

https://www.suse.com/security/cve/CVE-2020-13753.html
https://www.suse.com/security/cve/CVE-2020-9802.html
https://www.suse.com/security/cve/CVE-2020-9803.html
https://www.suse.com/security/cve/CVE-2020-9805.html
https://www.suse.com/security/cve/CVE-2020-9806.html
https://www.suse.com/security/cve/CVE-2020-9807.html
https://www.suse.com/security/cve/CVE-2020-9843.html
https://www.suse.com/security/cve/CVE-2020-9850.html
https://bugzilla.suse.com/1173998

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages