Mailinglist Archive: opensuse-security-announce (73 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0790-1: important: Security update for gnutls
openSUSE Security Update: Security update for gnutls
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0790-1
Rating: important
References: #1172461 #1172506
Cross-References: CVE-2020-13777
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for gnutls fixes the following issues:

- CVE-2020-13777: Fixed an insecure session ticket key construction which
could have made the TLS server to not bind the session ticket encryption
key with a value supplied by the application until the initial key
rotation, allowing an attacker to bypass authentication in TLS 1.3 and
recover previous conversations in TLS 1.2 (bsc#1172506).
- Fixed an improper handling of certificate chain with cross-signed
intermediate CA certificates (bsc#1172461).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-790=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

gnutls-3.6.7-lp151.2.18.1
gnutls-debuginfo-3.6.7-lp151.2.18.1
gnutls-debugsource-3.6.7-lp151.2.18.1
gnutls-guile-3.6.7-lp151.2.18.1
gnutls-guile-debuginfo-3.6.7-lp151.2.18.1
libgnutls-dane-devel-3.6.7-lp151.2.18.1
libgnutls-dane0-3.6.7-lp151.2.18.1
libgnutls-dane0-debuginfo-3.6.7-lp151.2.18.1
libgnutls-devel-3.6.7-lp151.2.18.1
libgnutls30-3.6.7-lp151.2.18.1
libgnutls30-debuginfo-3.6.7-lp151.2.18.1
libgnutls30-hmac-3.6.7-lp151.2.18.1
libgnutlsxx-devel-3.6.7-lp151.2.18.1
libgnutlsxx28-3.6.7-lp151.2.18.1
libgnutlsxx28-debuginfo-3.6.7-lp151.2.18.1

- openSUSE Leap 15.1 (x86_64):

libgnutls-devel-32bit-3.6.7-lp151.2.18.1
libgnutls30-32bit-3.6.7-lp151.2.18.1
libgnutls30-32bit-debuginfo-3.6.7-lp151.2.18.1
libgnutls30-hmac-32bit-3.6.7-lp151.2.18.1


References:

https://www.suse.com/security/cve/CVE-2020-13777.html
https://bugzilla.suse.com/1172461
https://bugzilla.suse.com/1172506

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages