Mailinglist Archive: opensuse-security-announce (69 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0693-1: moderate: Security update for dpdk
openSUSE Security Update: Security update for dpdk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0693-1
Rating: moderate
References: #1171477
Cross-References: CVE-2020-10722 CVE-2020-10723 CVE-2020-10724
CVE-2020-10725 CVE-2020-10726
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for dpdk fixes the following issues:

Security issues fixed:

- CVE-2020-10722: Fixed an integer overflow in vhost_user_set_log_base()
(bsc#1171477).
- CVE-2020-10723: Fixed an integer truncation in
vhost_user_check_and_alloc_queue_pair() (bsc#1171477).
- CVE-2020-10724: Fixed a missing inputs validation in Vhost-crypto
(bsc#1171477).
- CVE-2020-10725: Fixed a segfault caused by invalid virtio descriptors
sent from a malicious guest (bsc#1171477).
- CVE-2020-10726: Fixed a denial-of-service caused by
VHOST_USER_GET_INFLIGHT_FD message flooding (bsc#1171477).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-693=1



Package List:

- openSUSE Leap 15.1 (x86_64):

dpdk-18.11.3-lp151.3.4.1
dpdk-debuginfo-18.11.3-lp151.3.4.1
dpdk-debugsource-18.11.3-lp151.3.4.1
dpdk-devel-18.11.3-lp151.3.4.1
dpdk-devel-debuginfo-18.11.3-lp151.3.4.1
dpdk-examples-18.11.3-lp151.3.4.1
dpdk-examples-debuginfo-18.11.3-lp151.3.4.1
dpdk-kmp-default-18.11.3_k4.12.14_lp151.28.48-lp151.3.4.1
dpdk-kmp-default-debuginfo-18.11.3_k4.12.14_lp151.28.48-lp151.3.4.1
dpdk-tools-18.11.3-lp151.3.4.1
dpdk-tools-debuginfo-18.11.3-lp151.3.4.1
libdpdk-18_11-18.11.3-lp151.3.4.1
libdpdk-18_11-debuginfo-18.11.3-lp151.3.4.1

- openSUSE Leap 15.1 (noarch):

dpdk-doc-18.11.3-lp151.3.4.1


References:

https://www.suse.com/security/cve/CVE-2020-10722.html
https://www.suse.com/security/cve/CVE-2020-10723.html
https://www.suse.com/security/cve/CVE-2020-10724.html
https://www.suse.com/security/cve/CVE-2020-10725.html
https://www.suse.com/security/cve/CVE-2020-10726.html
https://bugzilla.suse.com/1171477

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages