Mailinglist Archive: opensuse-security-announce (38 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0165-1: important: Security update for wicked
openSUSE Security Update: Security update for wicked
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0165-1
Rating: important
References: #1160903 #1160905
Cross-References: CVE-2019-18902 CVE-2020-7216
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for wicked fixes the following issues:

- CVE-2019-18902: Fixed a use-after-free when receiving invalid DHCP6
client options (bsc#1160903).
- CVE-2020-7216: Fixed a potential denial of service via a memory leak
when processing packets with missing message type option in DHCP4
(bsc#1160905).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-165=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

wicked-0.6.60-lp151.2.6.1
wicked-debuginfo-0.6.60-lp151.2.6.1
wicked-debugsource-0.6.60-lp151.2.6.1
wicked-service-0.6.60-lp151.2.6.1


References:

https://www.suse.com/security/cve/CVE-2019-18902.html
https://www.suse.com/security/cve/CVE-2020-7216.html
https://bugzilla.suse.com/1160903
https://bugzilla.suse.com/1160905

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages