Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2536-1: moderate: Security update for slurm
openSUSE Security Update: Security update for slurm
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2536-1
Rating: moderate
References: #1140709 #1153095 #1153245
Cross-References: CVE-2019-12838
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for slurm fixes the following issues:

Security issue fixed:

- CVE-2019-12838: Fixed an SQL injection (bsc#1140709).

Non-security issue fixed:

- Added X11-forwarding (bsc#1153245).
- Moved srun from 'slurm' to 'slurm-node': srun is required on the nodes
as well so sbatch will work. 'slurm-node' is a requirement when 'slurm'
is installed (bsc#1153095).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2536=1



Package List:

- openSUSE Leap 15.0 (x86_64):

libpmi0-17.11.13-lp150.5.24.1
libpmi0-debuginfo-17.11.13-lp150.5.24.1
libslurm32-17.11.13-lp150.5.24.1
libslurm32-debuginfo-17.11.13-lp150.5.24.1
perl-slurm-17.11.13-lp150.5.24.1
perl-slurm-debuginfo-17.11.13-lp150.5.24.1
slurm-17.11.13-lp150.5.24.1
slurm-auth-none-17.11.13-lp150.5.24.1
slurm-auth-none-debuginfo-17.11.13-lp150.5.24.1
slurm-config-17.11.13-lp150.5.24.1
slurm-debuginfo-17.11.13-lp150.5.24.1
slurm-debugsource-17.11.13-lp150.5.24.1
slurm-devel-17.11.13-lp150.5.24.1
slurm-doc-17.11.13-lp150.5.24.1
slurm-lua-17.11.13-lp150.5.24.1
slurm-lua-debuginfo-17.11.13-lp150.5.24.1
slurm-munge-17.11.13-lp150.5.24.1
slurm-munge-debuginfo-17.11.13-lp150.5.24.1
slurm-node-17.11.13-lp150.5.24.1
slurm-node-debuginfo-17.11.13-lp150.5.24.1
slurm-openlava-17.11.13-lp150.5.24.1
slurm-pam_slurm-17.11.13-lp150.5.24.1
slurm-pam_slurm-debuginfo-17.11.13-lp150.5.24.1
slurm-plugins-17.11.13-lp150.5.24.1
slurm-plugins-debuginfo-17.11.13-lp150.5.24.1
slurm-seff-17.11.13-lp150.5.24.1
slurm-sjstat-17.11.13-lp150.5.24.1
slurm-slurmdbd-17.11.13-lp150.5.24.1
slurm-slurmdbd-debuginfo-17.11.13-lp150.5.24.1
slurm-sql-17.11.13-lp150.5.24.1
slurm-sql-debuginfo-17.11.13-lp150.5.24.1
slurm-sview-17.11.13-lp150.5.24.1
slurm-sview-debuginfo-17.11.13-lp150.5.24.1
slurm-torque-17.11.13-lp150.5.24.1
slurm-torque-debuginfo-17.11.13-lp150.5.24.1


References:

https://www.suse.com/security/cve/CVE-2019-12838.html
https://bugzilla.suse.com/1140709
https://bugzilla.suse.com/1153095
https://bugzilla.suse.com/1153245

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages