Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2472-1: moderate: Security update for python-ecdsa
openSUSE Security Update: Security update for python-ecdsa
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2472-1
Rating: moderate
References: #1153165 #1154217
Cross-References: CVE-2019-14853 CVE-2019-14859
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for python-ecdsa to version 0.13.3 fixes the following issues:

Security issues fixed:

- CVE-2019-14853: Fixed unexpected exceptions during signature decoding
(bsc#1153165).
- CVE-2019-14859: Fixed a signature malleability caused by insufficient
checks of DER encoding (bsc#1154217).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2472=1



Package List:

- openSUSE Leap 15.0 (noarch):

python2-ecdsa-0.13.3-lp150.2.3.1
python3-ecdsa-0.13.3-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2019-14853.html
https://www.suse.com/security/cve/CVE-2019-14859.html
https://bugzilla.suse.com/1153165
https://bugzilla.suse.com/1154217

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages