Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2235-1: moderate: Security update for u-boot
openSUSE Security Update: Security update for u-boot
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2235-1
Rating: moderate
References: #1144656 #1144675
Cross-References: CVE-2019-13104 CVE-2019-13106
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for u-boot fixes the following issues:

Security issues fixed:

- CVE-2019-13106: Fixed stack buffer overflow via a crafted ext4
filesystem that may lead to code execution (bsc#1144656).
- CVE-2019-13104: Fixed an underflow that could cause memcpy() to
overwrite a very large amount of data via a crafted ext4 filesystem
(bsc#1144675).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2235=1



Package List:

- openSUSE Leap 15.0 (x86_64):

u-boot-tools-2018.03-lp150.4.3.1
u-boot-tools-debuginfo-2018.03-lp150.4.3.1


References:

https://www.suse.com/security/cve/CVE-2019-13104.html
https://www.suse.com/security/cve/CVE-2019-13106.html
https://bugzilla.suse.com/1144656
https://bugzilla.suse.com/1144675

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages