Mailinglist Archive: opensuse-security-announce (95 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2067-1: Security update for wavpack
openSUSE Security Update: Security update for wavpack
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2067-1
Rating: low
References: #1133384 #1141334
Cross-References: CVE-2019-1010319 CVE-2019-11498
Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for wavpack fixes the following issues:

Security issues fixed:

- CVE-2019-1010319: Fixed use of uninitialized variable in
ParseWave64HeaderConfig that can result in unexpected control flow,
crashes, and segfaults (bsc#1141334).
- CVE-2019-11498: Fixed possible denial of service (application crash) in
WavpackSetConfiguration64 via a DFF file that lacks valid sample-rate
data (bsc#1133384).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2067=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2067=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libwavpack1-5.1.0-lp151.5.3.1
libwavpack1-debuginfo-5.1.0-lp151.5.3.1
wavpack-5.1.0-lp151.5.3.1
wavpack-debuginfo-5.1.0-lp151.5.3.1
wavpack-debugsource-5.1.0-lp151.5.3.1
wavpack-devel-5.1.0-lp151.5.3.1

- openSUSE Leap 15.1 (x86_64):

libwavpack1-32bit-5.1.0-lp151.5.3.1
libwavpack1-32bit-debuginfo-5.1.0-lp151.5.3.1

- openSUSE Leap 15.0 (i586 x86_64):

libwavpack1-5.1.0-lp150.3.6.1
libwavpack1-debuginfo-5.1.0-lp150.3.6.1
wavpack-5.1.0-lp150.3.6.1
wavpack-debuginfo-5.1.0-lp150.3.6.1
wavpack-debugsource-5.1.0-lp150.3.6.1
wavpack-devel-5.1.0-lp150.3.6.1

- openSUSE Leap 15.0 (x86_64):

libwavpack1-32bit-5.1.0-lp150.3.6.1
libwavpack1-32bit-debuginfo-5.1.0-lp150.3.6.1


References:

https://www.suse.com/security/cve/CVE-2019-1010319.html
https://www.suse.com/security/cve/CVE-2019-11498.html
https://bugzilla.suse.com/1133384
https://bugzilla.suse.com/1141334

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages