Mailinglist Archive: opensuse-security-announce (95 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2051-1: important: Security update for apache2
openSUSE Security Update: Security update for apache2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2051-1
Rating: important
References: #1145575 #1145738 #1145739 #1145740 #1145741
#1145742
Cross-References: CVE-2019-10081 CVE-2019-10082 CVE-2019-10092
CVE-2019-10097 CVE-2019-10098 CVE-2019-9517

Affected Products:
openSUSE Leap 15.1
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for apache2 fixes the following issues:

Security issues fixed:

- CVE-2019-9517: Fixed HTTP/2 implementations that are vulnerable to
unconstrained interal data buffering (bsc#1145575).
- CVE-2019-10081: Fixed mod_http2 that is vulnerable to memory corruption
on early pushes (bsc#1145742).
- CVE-2019-10082: Fixed mod_http2 that is vulnerable to read-after-free in
h2 connection shutdown (bsc#1145741).
- CVE-2019-10092: Fixed limited cross-site scripting in mod_proxy
(bsc#1145740).
- CVE-2019-10097: Fixed mod_remoteip stack buffer overflow and NULL
pointer dereference (bsc#1145739).
- CVE-2019-10098: Fixed mod_rewrite configuration vulnerablility to open
redirect (bsc#1145738).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2051=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-2051=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

apache2-2.4.33-lp151.8.6.1
apache2-debuginfo-2.4.33-lp151.8.6.1
apache2-debugsource-2.4.33-lp151.8.6.1
apache2-devel-2.4.33-lp151.8.6.1
apache2-event-2.4.33-lp151.8.6.1
apache2-event-debuginfo-2.4.33-lp151.8.6.1
apache2-example-pages-2.4.33-lp151.8.6.1
apache2-prefork-2.4.33-lp151.8.6.1
apache2-prefork-debuginfo-2.4.33-lp151.8.6.1
apache2-utils-2.4.33-lp151.8.6.1
apache2-utils-debuginfo-2.4.33-lp151.8.6.1
apache2-worker-2.4.33-lp151.8.6.1
apache2-worker-debuginfo-2.4.33-lp151.8.6.1

- openSUSE Leap 15.1 (noarch):

apache2-doc-2.4.33-lp151.8.6.1

- openSUSE Leap 15.0 (i586 x86_64):

apache2-2.4.33-lp150.2.23.1
apache2-debuginfo-2.4.33-lp150.2.23.1
apache2-debugsource-2.4.33-lp150.2.23.1
apache2-devel-2.4.33-lp150.2.23.1
apache2-event-2.4.33-lp150.2.23.1
apache2-event-debuginfo-2.4.33-lp150.2.23.1
apache2-example-pages-2.4.33-lp150.2.23.1
apache2-prefork-2.4.33-lp150.2.23.1
apache2-prefork-debuginfo-2.4.33-lp150.2.23.1
apache2-utils-2.4.33-lp150.2.23.1
apache2-utils-debuginfo-2.4.33-lp150.2.23.1
apache2-worker-2.4.33-lp150.2.23.1
apache2-worker-debuginfo-2.4.33-lp150.2.23.1

- openSUSE Leap 15.0 (noarch):

apache2-doc-2.4.33-lp150.2.23.1


References:

https://www.suse.com/security/cve/CVE-2019-10081.html
https://www.suse.com/security/cve/CVE-2019-10082.html
https://www.suse.com/security/cve/CVE-2019-10092.html
https://www.suse.com/security/cve/CVE-2019-10097.html
https://www.suse.com/security/cve/CVE-2019-10098.html
https://www.suse.com/security/cve/CVE-2019-9517.html
https://bugzilla.suse.com/1145575
https://bugzilla.suse.com/1145738
https://bugzilla.suse.com/1145739
https://bugzilla.suse.com/1145740
https://bugzilla.suse.com/1145741
https://bugzilla.suse.com/1145742

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages