Mailinglist Archive: opensuse-security-announce (90 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1915-1: important: Security update for mariadb, mariadb-connector-c
openSUSE Security Update: Security update for mariadb, mariadb-connector-c
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1915-1
Rating: important
References: #1126088 #1132666 #1136035
Cross-References: CVE-2019-2614 CVE-2019-2627 CVE-2019-2628

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for mariadb and mariadb-connector-c fixes the following issues:

mariadb:

- Update to version 10.2.25 (bsc#1136035)
- CVE-2019-2628: Fixed a remote denial of service by an privileged
attacker (bsc#1136035).
- CVE-2019-2627: Fixed another remote denial of service by an privileged
attacker (bsc#1136035).
- CVE-2019-2614: Fixed a potential remote denial of service by an
privileged attacker (bsc#1136035).
- Fixed reading options for multiple instances if my${INSTANCE}.cnf is
used (bsc#1132666)

mariadb-connector-c:

- Update to version 3.1.2 (bsc#1136035)
- Moved libmariadb.pc from /usr/lib/pkgconfig to /usr/lib64/pkgconfig for
x86_64 (bsc#1126088)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1915=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libmariadb-devel-3.1.2-lp150.10.1
libmariadb-devel-debuginfo-3.1.2-lp150.10.1
libmariadb3-3.1.2-lp150.10.1
libmariadb3-debuginfo-3.1.2-lp150.10.1
libmariadb_plugins-3.1.2-lp150.10.1
libmariadb_plugins-debuginfo-3.1.2-lp150.10.1
libmariadbprivate-3.1.2-lp150.10.1
libmariadbprivate-debuginfo-3.1.2-lp150.10.1
libmysqld-devel-10.2.25-lp150.2.13.1
libmysqld19-10.2.25-lp150.2.13.1
libmysqld19-debuginfo-10.2.25-lp150.2.13.1
mariadb-10.2.25-lp150.2.13.1
mariadb-bench-10.2.25-lp150.2.13.1
mariadb-bench-debuginfo-10.2.25-lp150.2.13.1
mariadb-client-10.2.25-lp150.2.13.1
mariadb-client-debuginfo-10.2.25-lp150.2.13.1
mariadb-connector-c-debugsource-3.1.2-lp150.10.1
mariadb-debuginfo-10.2.25-lp150.2.13.1
mariadb-debugsource-10.2.25-lp150.2.13.1
mariadb-galera-10.2.25-lp150.2.13.1
mariadb-test-10.2.25-lp150.2.13.1
mariadb-test-debuginfo-10.2.25-lp150.2.13.1
mariadb-tools-10.2.25-lp150.2.13.1
mariadb-tools-debuginfo-10.2.25-lp150.2.13.1

- openSUSE Leap 15.0 (noarch):

mariadb-errormessages-10.2.25-lp150.2.13.1

- openSUSE Leap 15.0 (x86_64):

libmariadb3-32bit-3.1.2-lp150.10.1
libmariadb3-32bit-debuginfo-3.1.2-lp150.10.1


References:

https://www.suse.com/security/cve/CVE-2019-2614.html
https://www.suse.com/security/cve/CVE-2019-2627.html
https://www.suse.com/security/cve/CVE-2019-2628.html
https://bugzilla.suse.com/1126088
https://bugzilla.suse.com/1132666
https://bugzilla.suse.com/1136035

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages