Mailinglist Archive: opensuse-security-announce (74 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1388-1: moderate: Security update for signing-party
openSUSE Security Update: Security update for signing-party
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1388-1
Rating: moderate
References: #1134040
Cross-References: CVE-2019-11627
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for signing-party fixes the following issues:

- CVE-2019-11627: The gpg-key2ps tool in signing-party contained an unsafe
shell call enabling shell injection via a User ID.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1388=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1388=1



Package List:

- openSUSE Leap 42.3 (noarch):

signing-party-2.1-10.3.1

- openSUSE Leap 15.0 (x86_64):

signing-party-2.7-lp150.5.1
signing-party-debuginfo-2.7-lp150.5.1
signing-party-debugsource-2.7-lp150.5.1


References:

https://www.suse.com/security/cve/CVE-2019-11627.html
https://bugzilla.suse.com/1134040

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages