Mailinglist Archive: opensuse-security-announce (108 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1143-1: moderate: Security update for ntp
openSUSE Security Update: Security update for ntp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1143-1
Rating: moderate
References: #1128525
Cross-References: CVE-2019-8936
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for ntp fixes the following issues:

Security issue fixed:

- CVE-2019-8936: Fixed a null pointer exception which could allow an
authenticated attcker to cause segmentation fault to ntpd (bsc#1128525).

Other issues addressed:

- Fixed several bugs in the BANCOMM reclock driver.
- Fixed ntp_loopfilter.c snprintf compilation warnings.
- Fixed spurious initgroups() error message.
- Fixed STA_NANO struct timex units.
- Fixed GPS week rollover in libparse.
- Fixed incorrect poll interval in packet.
- Added a missing check for ENABLE_CMAC.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-1143=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

ntp-4.2.8p13-lp150.8.1
ntp-debuginfo-4.2.8p13-lp150.8.1
ntp-debugsource-4.2.8p13-lp150.8.1
ntp-doc-4.2.8p13-lp150.8.1


References:

https://www.suse.com/security/cve/CVE-2019-8936.html
https://bugzilla.suse.com/1128525

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages