Mailinglist Archive: opensuse-security-announce (108 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:1140-1: moderate: Security update for gd
openSUSE Security Update: Security update for gd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1140-1
Rating: moderate
References: #1123361 #1123522
Cross-References: CVE-2019-6977 CVE-2019-6978
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for gd fixes the following issues:

Security issues fixed:

- CVE-2019-6977: Fixed a heap-based buffer overflow the GD Graphics
Library used in the imagecolormatch function (bsc#1123361).
- CVE-2019-6978: Fixed a double free in the gdImage*Ptr() functions
(bsc#1123522).

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-1140=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

gd-2.1.0-30.1
gd-debuginfo-2.1.0-30.1
gd-debugsource-2.1.0-30.1
gd-devel-2.1.0-30.1

- openSUSE Leap 42.3 (x86_64):

gd-32bit-2.1.0-30.1
gd-debuginfo-32bit-2.1.0-30.1


References:

https://www.suse.com/security/cve/CVE-2019-6977.html
https://www.suse.com/security/cve/CVE-2019-6978.html
https://bugzilla.suse.com/1123361
https://bugzilla.suse.com/1123522

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages