Mailinglist Archive: opensuse-security-announce (76 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:0216-1: important: Security update for chromium
openSUSE Security Update: Security update for chromium
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0216-1
Rating: important
References: #1123641 #1124936
Cross-References: CVE-2019-5754 CVE-2019-5755 CVE-2019-5756
CVE-2019-5757 CVE-2019-5758 CVE-2019-5759
CVE-2019-5760 CVE-2019-5761 CVE-2019-5762
CVE-2019-5763 CVE-2019-5764 CVE-2019-5765
CVE-2019-5766 CVE-2019-5767 CVE-2019-5768
CVE-2019-5769 CVE-2019-5770 CVE-2019-5771
CVE-2019-5772 CVE-2019-5773 CVE-2019-5774
CVE-2019-5775 CVE-2019-5776 CVE-2019-5777
CVE-2019-5778 CVE-2019-5779 CVE-2019-5780
CVE-2019-5781 CVE-2019-5782 CVE-2019-5784

Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes 30 vulnerabilities is now available.

Description:

This update for Chromium to version 72.0.3626.96 fixes the following
issues:

Security issues fixed (bsc#1123641 and bsc#1124936):

- CVE-2019-5784: Inappropriate implementation in V8
- CVE-2019-5754: Inappropriate implementation in QUIC Networking.
- CVE-2019-5782: Inappropriate implementation in V8.
- CVE-2019-5755: Inappropriate implementation in V8.
- CVE-2019-5756: Use after free in PDFium.
- CVE-2019-5757: Type Confusion in SVG.
- CVE-2019-5758: Use after free in Blink.
- CVE-2019-5759: Use after free in HTML select elements.
- CVE-2019-5760: Use after free in WebRTC.
- CVE-2019-5761: Use after free in SwiftShader.
- CVE-2019-5762: Use after free in PDFium.
- CVE-2019-5763: Insufficient validation of untrusted input in V8.
- CVE-2019-5764: Use after free in WebRTC.
- CVE-2019-5765: Insufficient policy enforcement in the browser.
- CVE-2019-5766: Insufficient policy enforcement in Canvas.
- CVE-2019-5767: Incorrect security UI in WebAPKs.
- CVE-2019-5768: Insufficient policy enforcement in DevTools.
- CVE-2019-5769: Insufficient validation of untrusted input in Blink.
- CVE-2019-5770: Heap buffer overflow in WebGL.
- CVE-2019-5771: Heap buffer overflow in SwiftShader.
- CVE-2019-5772: Use after free in PDFium.
- CVE-2019-5773: Insufficient data validation in IndexedDB.
- CVE-2019-5774: Insufficient validation of untrusted input in
SafeBrowsing.
- CVE-2019-5775: Insufficient policy enforcement in Omnibox.
- CVE-2019-5776: Insufficient policy enforcement in Omnibox.
- CVE-2019-5777: Insufficient policy enforcement in Omnibox.
- CVE-2019-5778: Insufficient policy enforcement in Extensions.
- CVE-2019-5779: Insufficient policy enforcement in ServiceWorker.
- CVE-2019-5780: Insufficient policy enforcement.
- CVE-2019-5781: Insufficient policy enforcement in Omnibox.

For a full list of changes refer to
https://chromereleases.googleblog.com/2019/02/stable-channel-update-for-des
ktop.html

This update was imported from the openSUSE:Leap:15.0:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-216=1



Package List:

- openSUSE Backports SLE-15 (aarch64 x86_64):

chromedriver-72.0.3626.96-bp150.2.32.1
chromium-72.0.3626.96-bp150.2.32.1


References:

https://www.suse.com/security/cve/CVE-2019-5754.html
https://www.suse.com/security/cve/CVE-2019-5755.html
https://www.suse.com/security/cve/CVE-2019-5756.html
https://www.suse.com/security/cve/CVE-2019-5757.html
https://www.suse.com/security/cve/CVE-2019-5758.html
https://www.suse.com/security/cve/CVE-2019-5759.html
https://www.suse.com/security/cve/CVE-2019-5760.html
https://www.suse.com/security/cve/CVE-2019-5761.html
https://www.suse.com/security/cve/CVE-2019-5762.html
https://www.suse.com/security/cve/CVE-2019-5763.html
https://www.suse.com/security/cve/CVE-2019-5764.html
https://www.suse.com/security/cve/CVE-2019-5765.html
https://www.suse.com/security/cve/CVE-2019-5766.html
https://www.suse.com/security/cve/CVE-2019-5767.html
https://www.suse.com/security/cve/CVE-2019-5768.html
https://www.suse.com/security/cve/CVE-2019-5769.html
https://www.suse.com/security/cve/CVE-2019-5770.html
https://www.suse.com/security/cve/CVE-2019-5771.html
https://www.suse.com/security/cve/CVE-2019-5772.html
https://www.suse.com/security/cve/CVE-2019-5773.html
https://www.suse.com/security/cve/CVE-2019-5774.html
https://www.suse.com/security/cve/CVE-2019-5775.html
https://www.suse.com/security/cve/CVE-2019-5776.html
https://www.suse.com/security/cve/CVE-2019-5777.html
https://www.suse.com/security/cve/CVE-2019-5778.html
https://www.suse.com/security/cve/CVE-2019-5779.html
https://www.suse.com/security/cve/CVE-2019-5780.html
https://www.suse.com/security/cve/CVE-2019-5781.html
https://www.suse.com/security/cve/CVE-2019-5782.html
https://www.suse.com/security/cve/CVE-2019-5784.html
https://bugzilla.suse.com/1123641
https://bugzilla.suse.com/1124936

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages