Mailinglist Archive: opensuse-security-announce (52 mails)

< Previous Next >
[security-announce] openSUSE-SU-2018:3646-1: important: Security update for MozillaThunderbird
openSUSE Security Update: Security update for MozillaThunderbird
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3646-1
Rating: important
References: #1112852
Cross-References: CVE-2018-12389 CVE-2018-12390 CVE-2018-12391
CVE-2018-12392 CVE-2018-12393
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for MozillaThunderbird fixes the following issues:

Thunderbird 63 ESR was updated to version 60.3.0 to fix the following
issues (bsc#1112852):

Security issues fixed (MFSA 2018-28):

- CVE-2018-12389: Fixed memory safety bugs.
- CVE-2018-12390: Fixed memory safety bugs.
- CVE-2018-12391: Fixed HTTP Live Stream audio data is accessible
cross-origin.
- CVE-2018-12392: Fixed crash with nested event loops.
- CVE-2018-12393: Fixed integer overflow during Unicode conversion while
loading JavaScript.

Non-security issues fixed:

- various theme fixes
- Shift+PageUp/PageDown in Write window
- Gloda attachment filtering
- Mailing list address auto-complete enter/return handling
- Thunderbird hung if HTML signature references non-existent image
- Filters not working for headers that appear more than once


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1340=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1340=1



Package List:

- openSUSE Leap 42.3 (x86_64):

MozillaThunderbird-60.3.0-80.1
MozillaThunderbird-buildsymbols-60.3.0-80.1
MozillaThunderbird-debuginfo-60.3.0-80.1
MozillaThunderbird-debugsource-60.3.0-80.1
MozillaThunderbird-translations-common-60.3.0-80.1
MozillaThunderbird-translations-other-60.3.0-80.1

- openSUSE Leap 15.0 (x86_64):

MozillaThunderbird-60.3.0-lp150.3.25.1
MozillaThunderbird-buildsymbols-60.3.0-lp150.3.25.1
MozillaThunderbird-debuginfo-60.3.0-lp150.3.25.1
MozillaThunderbird-debugsource-60.3.0-lp150.3.25.1
MozillaThunderbird-translations-common-60.3.0-lp150.3.25.1
MozillaThunderbird-translations-other-60.3.0-lp150.3.25.1


References:

https://www.suse.com/security/cve/CVE-2018-12389.html
https://www.suse.com/security/cve/CVE-2018-12390.html
https://www.suse.com/security/cve/CVE-2018-12391.html
https://www.suse.com/security/cve/CVE-2018-12392.html
https://www.suse.com/security/cve/CVE-2018-12393.html
https://bugzilla.suse.com/1112852

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages