Mailinglist Archive: opensuse-security-announce (85 mails)

< Previous Next >
[security-announce] openSUSE-SU-2018:2229-1: important: Security update for libofx
openSUSE Security Update: Security update for libofx
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2229-1
Rating: important
References: #1058673 #1061964
Cross-References: CVE-2017-2816 CVE-2017-2920
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for libofx fixes the following issues:

The following security vulnerabilities have been addressed:

- CVE-2017-2920: Fixed an exploitable buffer overflow in the tag parsing
functionality, which could result in an out of bounds write and could be
triggered via a specially crafted OFX file (boo#1061964)

- CVE-2017-2816: Fixed another buffer overflow in the tag parsing
functionality, which could result in an stack overflow and could be
triggered via a specially crafted OFX file (boo#1058673)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-820=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

libofx-0.9.10-7.3.1
libofx-debuginfo-0.9.10-7.3.1
libofx-debugsource-0.9.10-7.3.1
libofx-devel-0.9.10-7.3.1
libofx6-0.9.10-7.3.1
libofx6-debuginfo-0.9.10-7.3.1


References:

https://www.suse.com/security/cve/CVE-2017-2816.html
https://www.suse.com/security/cve/CVE-2017-2920.html
https://bugzilla.suse.com/1058673
https://bugzilla.suse.com/1061964

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages