Mailinglist Archive: opensuse-security-announce (57 mails)

< Previous Next >
[security-announce] openSUSE-SU-2018:1722-1: moderate: Security update for python-python-gnupg
openSUSE Security Update: Security update for python-python-gnupg
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1722-1
Rating: moderate
References: #1096745
Cross-References: CVE-2018-12020
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for python-python-gnupg to version 0.4.3 fixes the following
issues:

The following security vulnerabilities were addressed:

- Sanitize diagnostic output of the original file name in verbose mode
(CVE-2018-12020 boo#1096745)

The following other changes were made:

- Add --no-verbose to the gpg command line, in case verbose is specified
is gpg.conf.
- Add expect_passphrase password for use on GnuPG >= 2.1 when passing
passphrase to gpg via pinentry
- Provide a trust_keys method to allow setting the trust level for keys
- When the gpg executable is not found, note the path used in the
exception message
- Make error messages more informational


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-646=1



Package List:

- openSUSE Leap 15.0 (noarch):

python2-python-gnupg-0.4.3-lp150.2.3.1
python3-python-gnupg-0.4.3-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-12020.html
https://bugzilla.suse.com/1096745

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages