Mailinglist Archive: opensuse-security-announce (57 mails)

< Previous Next >
[security-announce] openSUSE-SU-2018:1553-1: important: Security update for git
openSUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1553-1
Rating: important
References: #1095218 #1095219
Cross-References: CVE-2018-11233 CVE-2018-11235
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for fixes the following security issues:

* path sanity-checks on NTFS can read arbitrary memory (CVE-2018-11233,
boo#1095218)
* arbitrary code execution when recursively cloning a malicious repository
(CVE-2018-11235, boo#1095219)


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-557=1

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-557=1



Package List:

- openSUSE Leap 42.3 (i586 x86_64):

git-2.13.7-13.1
git-arch-2.13.7-13.1
git-core-2.13.7-13.1
git-core-debuginfo-2.13.7-13.1
git-credential-gnome-keyring-2.13.7-13.1
git-credential-gnome-keyring-debuginfo-2.13.7-13.1
git-cvs-2.13.7-13.1
git-daemon-2.13.7-13.1
git-daemon-debuginfo-2.13.7-13.1
git-debugsource-2.13.7-13.1
git-email-2.13.7-13.1
git-gui-2.13.7-13.1
git-svn-2.13.7-13.1
git-svn-debuginfo-2.13.7-13.1
git-web-2.13.7-13.1
gitk-2.13.7-13.1

- openSUSE Leap 42.3 (noarch):

git-doc-2.13.7-13.1

- openSUSE Leap 15.0 (i586 x86_64):

git-2.16.4-lp150.2.3.1
git-arch-2.16.4-lp150.2.3.1
git-core-2.16.4-lp150.2.3.1
git-core-debuginfo-2.16.4-lp150.2.3.1
git-credential-gnome-keyring-2.16.4-lp150.2.3.1
git-credential-gnome-keyring-debuginfo-2.16.4-lp150.2.3.1
git-credential-libsecret-2.16.4-lp150.2.3.1
git-credential-libsecret-debuginfo-2.16.4-lp150.2.3.1
git-cvs-2.16.4-lp150.2.3.1
git-daemon-2.16.4-lp150.2.3.1
git-daemon-debuginfo-2.16.4-lp150.2.3.1
git-debuginfo-2.16.4-lp150.2.3.1
git-debugsource-2.16.4-lp150.2.3.1
git-email-2.16.4-lp150.2.3.1
git-gui-2.16.4-lp150.2.3.1
git-p4-2.16.4-lp150.2.3.1
git-svn-2.16.4-lp150.2.3.1
git-svn-debuginfo-2.16.4-lp150.2.3.1
git-web-2.16.4-lp150.2.3.1
gitk-2.16.4-lp150.2.3.1

- openSUSE Leap 15.0 (noarch):

git-doc-2.16.4-lp150.2.3.1


References:

https://www.suse.com/security/cve/CVE-2018-11233.html
https://www.suse.com/security/cve/CVE-2018-11235.html
https://bugzilla.suse.com/1095218
https://bugzilla.suse.com/1095219

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages