Mailinglist Archive: opensuse-security-announce (83 mails)

< Previous Next >
[security-announce] openSUSE-SU-2017:3069-1: important: Security update for tomcat
openSUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:3069-1
Rating: important
References: #1019016 #1042910 #1053352 #1059554 #977410

Cross-References: CVE-2017-12617 CVE-2017-5664 CVE-2017-7674

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that solves three vulnerabilities and has two
fixes is now available.

Description:

This update for tomcat fixes the following issues:

Security issues fixed:

- CVE-2017-5664: A problem in handling error pages was fixed, to avoid
potential file overwrites during error page handling. (bsc#1042910).
- CVE-2017-7674: A CORS Filter issue could lead to client and server side
cache poisoning (bsc#1053352)
- CVE-2017-12617: A remote code execution possibility via JSP Upload was
fixed (bsc#1059554)

Non security bugs fixed:

- Fix tomcat-digest classpath error (bsc#977410)
- Fix packaged /etc/alternatives symlinks for api libs that caused rpm -V
to report link mismatch (bsc#1019016)

This update was imported from the SUSE:SLE-12-SP2:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1299=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1299=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (noarch):

tomcat-8.0.43-9.1
tomcat-admin-webapps-8.0.43-9.1
tomcat-docs-webapp-8.0.43-9.1
tomcat-el-3_0-api-8.0.43-9.1
tomcat-embed-8.0.43-9.1
tomcat-javadoc-8.0.43-9.1
tomcat-jsp-2_3-api-8.0.43-9.1
tomcat-jsvc-8.0.43-9.1
tomcat-lib-8.0.43-9.1
tomcat-servlet-3_1-api-8.0.43-9.1
tomcat-webapps-8.0.43-9.1

- openSUSE Leap 42.2 (noarch):

tomcat-8.0.43-6.13.1
tomcat-admin-webapps-8.0.43-6.13.1
tomcat-docs-webapp-8.0.43-6.13.1
tomcat-el-3_0-api-8.0.43-6.13.1
tomcat-embed-8.0.43-6.13.1
tomcat-javadoc-8.0.43-6.13.1
tomcat-jsp-2_3-api-8.0.43-6.13.1
tomcat-jsvc-8.0.43-6.13.1
tomcat-lib-8.0.43-6.13.1
tomcat-servlet-3_1-api-8.0.43-6.13.1
tomcat-webapps-8.0.43-6.13.1


References:

https://www.suse.com/security/cve/CVE-2017-12617.html
https://www.suse.com/security/cve/CVE-2017-5664.html
https://www.suse.com/security/cve/CVE-2017-7674.html
https://bugzilla.suse.com/1019016
https://bugzilla.suse.com/1042910
https://bugzilla.suse.com/1053352
https://bugzilla.suse.com/1059554
https://bugzilla.suse.com/977410

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages