Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] SUSE-SU-2017:1558-1: important: Security update for mercurial
SUSE Security Update: Security update for mercurial
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:1558-1
Rating: important
References: #1043063 #1043502
Cross-References: CVE-2017-9462
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for mercurial fixes the following issues:

- CVE-2017-9462: Arbitrary code execution was possible by remote users via
"hg serve --stdio" (bsc#1043063):


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-mercurial-13144=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-mercurial-13144=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
s390x x86_64):

mercurial-2.3.2-0.17.1

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):

mercurial-debuginfo-2.3.2-0.17.1
mercurial-debugsource-2.3.2-0.17.1


References:

https://www.suse.com/security/cve/CVE-2017-9462.html
https://bugzilla.suse.com/1043063
https://bugzilla.suse.com/1043502

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages