Mailinglist Archive: opensuse-security-announce (38 mails)

< Previous Next >
[security-announce] SUSE-SU-2017:0914-1: important: Security update for ruby19
SUSE Security Update: Security update for ruby19
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:0914-1
Rating: important
References: #1018808 #986630
Cross-References: CVE-2016-2339
Affected Products:
SUSE Studio Onsite Runner 1.3
SUSE Studio Onsite 1.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for ruby19 fixes the following issues:

Security issue fixed:
- CVE-2016-2339: heap overflow vulnerability in the
Fiddle::Function.new"initialize" (bsc#1018808)

Bugfixes:
- fix small mistake in the backport for (bsc#986630)
- HTTP Header injection in 'net/http' (bsc#986630)
- make the testsuite work with our new openssl requirements


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Studio Onsite Runner 1.3:

zypper in -t patch slestso13-ruby19-13046=1

- SUSE Studio Onsite 1.3:

zypper in -t patch slestso13-ruby19-13046=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Studio Onsite Runner 1.3 (s390x):

ruby19-1.9.3.p392-0.26.1

- SUSE Studio Onsite 1.3 (x86_64):

ruby19-1.9.3.p392-0.26.1
ruby19-devel-1.9.3.p392-0.26.1
ruby19-devel-extra-1.9.3.p392-0.26.1


References:

https://www.suse.com/security/cve/CVE-2016-2339.html
https://bugzilla.suse.com/1018808
https://bugzilla.suse.com/986630

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages