Mailinglist Archive: opensuse-security-announce (97 mails)

< Previous Next >
[security-announce] SUSE-SU-2016:0837-1: important: Security update for samba
SUSE Security Update: Security update for samba
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:0837-1
Rating: important
References: #967017 #968222
Cross-References: CVE-2015-7560
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Desktop 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


This update for samba fixes the following issues:

Security issue fixed:
- CVE-2015-7560: Getting and setting Windows ACLs on symlinks can change
permissions on link target; (bso#11648); (bsc#968222).

Bug fixed:
- Fix leaking memory in libsmbclient: Add missing talloc stackframe;
(bso#11177); (bsc#967017).


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-samba-12466=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-samba-12466=1

- SUSE Linux Enterprise Desktop 11-SP4:

zypper in -t patch sledsp4-samba-12466=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-samba-12466=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
s390x x86_64):

libldb-devel-3.6.3-67.2
libnetapi-devel-3.6.3-67.2
libnetapi0-3.6.3-67.2
libsmbclient-devel-3.6.3-67.2
libsmbsharemodes-devel-3.6.3-67.2
libsmbsharemodes0-3.6.3-67.2
libtalloc-devel-3.6.3-67.2
libtdb-devel-3.6.3-67.2
libtevent-devel-3.6.3-67.2
libwbclient-devel-3.6.3-67.2
samba-devel-3.6.3-67.2

- SUSE Linux Enterprise Software Development Kit 11-SP4 (ia64 ppc64 s390x
x86_64):

samba-test-3.6.3-67.2

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

ldapsmb-1.34b-67.2
libldb1-3.6.3-67.2
libsmbclient0-3.6.3-67.2
libtalloc2-3.6.3-67.2
libtdb1-3.6.3-67.2
libtevent0-3.6.3-67.2
libwbclient0-3.6.3-67.2
samba-3.6.3-67.2
samba-client-3.6.3-67.2
samba-krb-printing-3.6.3-67.2
samba-winbind-3.6.3-67.2

- SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):

libsmbclient0-32bit-3.6.3-67.2
libtalloc2-32bit-3.6.3-67.2
libtdb1-32bit-3.6.3-67.2
libtevent0-32bit-3.6.3-67.2
libwbclient0-32bit-3.6.3-67.2
samba-32bit-3.6.3-67.2
samba-client-32bit-3.6.3-67.2
samba-winbind-32bit-3.6.3-67.2

- SUSE Linux Enterprise Server 11-SP4 (noarch):

samba-doc-3.6.3-67.2

- SUSE Linux Enterprise Server 11-SP4 (ia64):

libsmbclient0-x86-3.6.3-67.2
libtalloc2-x86-3.6.3-67.2
libtdb1-x86-3.6.3-67.2
libtevent0-x86-3.6.3-67.2
libwbclient0-x86-3.6.3-67.2
samba-client-x86-3.6.3-67.2
samba-winbind-x86-3.6.3-67.2
samba-x86-3.6.3-67.2

- SUSE Linux Enterprise Desktop 11-SP4 (i586 x86_64):

libldb1-3.6.3-67.2
libsmbclient0-3.6.3-67.2
libtalloc2-3.6.3-67.2
libtdb1-3.6.3-67.2
libtevent0-3.6.3-67.2
libwbclient0-3.6.3-67.2
samba-3.6.3-67.2
samba-client-3.6.3-67.2
samba-krb-printing-3.6.3-67.2
samba-winbind-3.6.3-67.2

- SUSE Linux Enterprise Desktop 11-SP4 (x86_64):

libldb1-32bit-3.6.3-67.2
libsmbclient0-32bit-3.6.3-67.2
libtalloc2-32bit-3.6.3-67.2
libtdb1-32bit-3.6.3-67.2
libtevent0-32bit-3.6.3-67.2
libwbclient0-32bit-3.6.3-67.2
samba-32bit-3.6.3-67.2
samba-client-32bit-3.6.3-67.2
samba-winbind-32bit-3.6.3-67.2

- SUSE Linux Enterprise Desktop 11-SP4 (noarch):

samba-doc-3.6.3-67.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):

samba-debuginfo-3.6.3-67.2
samba-debugsource-3.6.3-67.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (ppc64 s390x x86_64):

samba-debuginfo-32bit-3.6.3-67.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (ia64):

samba-debuginfo-x86-3.6.3-67.2


References:

https://www.suse.com/security/cve/CVE-2015-7560.html
https://bugzilla.suse.com/967017
https://bugzilla.suse.com/968222

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages