Mailinglist Archive: opensuse-security-announce (27 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:1740-1: important: Security update for flash-player
SUSE Security Update: Security update for flash-player
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:1740-1
Rating: important
References: #950169
Cross-References: CVE-2015-5569 CVE-2015-7625 CVE-2015-7626
CVE-2015-7627 CVE-2015-7628 CVE-2015-7629
CVE-2015-7630 CVE-2015-7631 CVE-2015-7632
CVE-2015-7633 CVE-2015-7634 CVE-2015-7643
CVE-2015-7644
Affected Products:
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that fixes 13 vulnerabilities is now available.

Description:

flash-player was updated to version 11.2.202.535 to fix 13 security issues
(bsc#950169).

These security issues were fixed:
- A vulnerability that could be exploited to bypass the same-origin-policy
and lead to information disclosure (CVE-2015-7628).
- A defense-in-depth feature in the Flash broker API (CVE-2015-5569).
- Use-after-free vulnerabilities that could lead to code execution
(CVE-2015-7629, CVE-2015-7631, CVE-2015-7643, CVE-2015-7644).
- A buffer overflow vulnerability that could lead to code execution
(CVE-2015-7632).
- Memory corruption vulnerabilities that could lead to code execution
(CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630,
CVE-2015-7633, CVE-2015-7634).


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 12:

zypper in -t patch SUSE-SLE-WE-12-2015-680=1

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-680=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Workstation Extension 12 (x86_64):

flash-player-11.2.202.535-105.1
flash-player-gnome-11.2.202.535-105.1

- SUSE Linux Enterprise Desktop 12 (x86_64):

flash-player-11.2.202.535-105.1
flash-player-gnome-11.2.202.535-105.1


References:

https://www.suse.com/security/cve/CVE-2015-5569.html
https://www.suse.com/security/cve/CVE-2015-7625.html
https://www.suse.com/security/cve/CVE-2015-7626.html
https://www.suse.com/security/cve/CVE-2015-7627.html
https://www.suse.com/security/cve/CVE-2015-7628.html
https://www.suse.com/security/cve/CVE-2015-7629.html
https://www.suse.com/security/cve/CVE-2015-7630.html
https://www.suse.com/security/cve/CVE-2015-7631.html
https://www.suse.com/security/cve/CVE-2015-7632.html
https://www.suse.com/security/cve/CVE-2015-7633.html
https://www.suse.com/security/cve/CVE-2015-7634.html
https://www.suse.com/security/cve/CVE-2015-7643.html
https://www.suse.com/security/cve/CVE-2015-7644.html
https://bugzilla.suse.com/950169

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages