Mailinglist Archive: opensuse-security-announce (53 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:1255-1: critical: Security update for flash-player
SUSE Security Update: Security update for flash-player
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:1255-1
Rating: critical
References: #937752
Cross-References: CVE-2015-5122 CVE-2015-5123
Affected Products:
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

flash-player was updated to fix two security issues.

These security issues were fixed:
- CVE-2015-5123: Use-after-free vulnerability in the BitmapData class in
the ActionScript 3 (AS3) implementation in Adobe Flash Player allowed
remote attackers to execute arbitrary code or cause a denial of service
(memory corruption) via crafted Flash content that overrides a valueOf
function (bsc#937752).
- CVE-2015-5122: Use-after-free vulnerability in the DisplayObject class
in the ActionScript 3 (AS3) implementation in Adobe Flash Player allowed
remote attackers to execute arbitrary code or cause a denial of service
(memory corruption) via crafted Flash content that leverages improper
handling of the opaqueBackground property (bsc#937752).


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 12:

zypper in -t patch SUSE-SLE-WE-12-2015-323=1

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-323=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Workstation Extension 12 (i586 x86_64):

flash-player-11.2.202.491-96.1
flash-player-gnome-11.2.202.491-96.1

- SUSE Linux Enterprise Desktop 12 (i586 x86_64):

flash-player-11.2.202.491-96.1
flash-player-gnome-11.2.202.491-96.1


References:

https://www.suse.com/security/cve/CVE-2015-5122.html
https://www.suse.com/security/cve/CVE-2015-5123.html
https://bugzilla.suse.com/937752

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages