Mailinglist Archive: opensuse-security-announce (53 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:1183-1: important: Security update for OpenSSL
SUSE Security Update: Security update for OpenSSL
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:1183-1
Rating: important
References: #929678 #931698 #934489 #934491
Cross-References: CVE-2015-1789 CVE-2015-1790 CVE-2015-4000

Affected Products:
SUSE Linux Enterprise for SAP Applications 11 SP2
SUSE Linux Enterprise for SAP Applications 11 SP1
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:


OpenSSL was updated to fix several security issues.

* CVE-2015-4000: The Logjam Attack ( weakdh.org ) has been addressed
by rejecting connections with DH parameters shorter than 1024 bits.
We now also generate 2048-bit DH parameters by default.
* CVE-2015-1789: An out-of-bounds read in X509_cmp_time was fixed.
* CVE-2015-1790: A PKCS7 decoder crash with missing EnvelopedContent
was fixed.
* fixed a timing side channel in RSA decryption (bnc#929678)

Additional changes:

* In the default SSL cipher string EXPORT ciphers are now disabled.
This will only get active if applications get rebuilt and actually
use this string. (bnc#931698)

Security Issues:

* CVE-2015-1789
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1789>
* CVE-2015-1790
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1790>
* CVE-2015-4000
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-4000>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise for SAP Applications 11 SP2:

zypper in -t patch slesapp2-compat-openssl097g=10802

- SUSE Linux Enterprise for SAP Applications 11 SP1:

zypper in -t patch slesapp1-compat-openssl097g=10793

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise for SAP Applications 11 SP2 (x86_64):

compat-openssl097g-0.9.7g-146.22.31.1
compat-openssl097g-32bit-0.9.7g-146.22.31.1

- SUSE Linux Enterprise for SAP Applications 11 SP1 (x86_64):

compat-openssl097g-0.9.7g-146.22.31.1
compat-openssl097g-32bit-0.9.7g-146.22.31.1


References:

https://www.suse.com/security/cve/CVE-2015-1789.html
https://www.suse.com/security/cve/CVE-2015-1790.html
https://www.suse.com/security/cve/CVE-2015-4000.html
https://bugzilla.suse.com/929678
https://bugzilla.suse.com/931698
https://bugzilla.suse.com/934489
https://bugzilla.suse.com/934491

https://download.suse.com/patch/finder/?keywords=988a9debe1ac4ac25cd6b815d5382398

https://download.suse.com/patch/finder/?keywords=b18733973cc66be5941bc1514b5749d4

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages