Mailinglist Archive: opensuse-security-announce (32 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:1103-1: important: Security update for e2fsprogs
SUSE Security Update: Security update for e2fsprogs
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:1103-1
Rating: important
References: #915402 #918346
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Desktop 11-SP4
______________________________________________________________________________

An update that contains security fixes can now be installed.

Description:

This update provides the following security-fixes for e2fsprogs:

libext2fs: fix potential buffer overflow in closefs() (bsc#918346,
CVE-2015-1572) libext2fs: avoid buffer overflow if s_first_meta_bg is too
big (bsc#915402, CVE-2015-0247)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-e2fsprogs-219=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-e2fsprogs-219=1

- SUSE Linux Enterprise Desktop 11-SP4:

zypper in -t patch sledsp4-e2fsprogs-219=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64
s390x x86_64):

e2fsprogs-devel-1.41.9-2.14.2
libcom_err-devel-1.41.9-2.14.2
libext2fs-devel-1.41.9-2.14.2

- SUSE Linux Enterprise Software Development Kit 11-SP4 (ppc64 s390x x86_64):

libcom_err-devel-32bit-1.41.9-2.14.2
libext2fs-devel-32bit-1.41.9-2.14.2
libext2fs2-32bit-1.41.9-2.14.2

- SUSE Linux Enterprise Software Development Kit 11-SP4 (ia64):

libext2fs2-x86-1.41.9-2.14.2

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

e2fsprogs-1.41.9-2.14.2
libcom_err2-1.41.9-2.14.2
libext2fs2-1.41.9-2.14.2

- SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):

libcom_err2-32bit-1.41.9-2.14.2

- SUSE Linux Enterprise Server 11-SP4 (ia64):

libcom_err2-x86-1.41.9-2.14.2

- SUSE Linux Enterprise Desktop 11-SP4 (i586 x86_64):

e2fsprogs-1.41.9-2.14.2
libcom_err2-1.41.9-2.14.2
libext2fs2-1.41.9-2.14.2

- SUSE Linux Enterprise Desktop 11-SP4 (x86_64):

libcom_err2-32bit-1.41.9-2.14.2


References:

https://bugzilla.suse.com/915402
https://bugzilla.suse.com/918346

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages