Mailinglist Archive: opensuse-security-announce (28 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:0833-1: critical: Security update for java-1_7_0-openjdk
SUSE Security Update: Security update for java-1_7_0-openjdk
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:0833-1
Rating: critical
References: #927591
Cross-References: CVE-2015-0458 CVE-2015-0459 CVE-2015-0460
CVE-2015-0469 CVE-2015-0477 CVE-2015-0478
CVE-2015-0480 CVE-2015-0484 CVE-2015-0488
CVE-2015-0491 CVE-2015-0492
Affected Products:
SUSE Linux Enterprise Desktop 11 SP3
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.
It includes one version update.

Description:


OpenJDK was updated to version 2.5.5 - OpenJDK 7u79 to fix security issues
and bugs.

The following vulnerabilities have been fixed:

* CVE-2015-0458: Deployment: unauthenticated remote attackers could
execute arbitrary code via multiple protocols.
* CVE-2015-0459: 2D: unauthenticated remote attackers could execute
arbitrary code via multiple protocols.
* CVE-2015-0460: Hotspot: unauthenticated remote attackers could
execute arbitrary code via multiple protocols.
* CVE-2015-0469: 2D: unauthenticated remote attackers could execute
arbitrary code via multiple protocols.
* CVE-2015-0477: Beans: unauthenticated remote attackers could update,
insert or delete some JAVA accessible data via multiple protocols
* CVE-2015-0478: JCE: unauthenticated remote attackers could read some
JAVA accessible data via multiple protocols
* CVE-2015-0480: Tools: unauthenticated remote attackers could update,
insert or delete some JAVA accessible data via multiple protocols
and cause a partial denial of service (partial DOS)
* CVE-2015-0484: JavaFX: unauthenticated remote attackers could read,
update, insert or delete access some Java accessible data via
multiple protocols and cause a partial denial of service (partial
DOS).
* CVE-2015-0488: JSSE: unauthenticated remote attackers could cause a
partial denial of service (partial DOS).
* CVE-2015-0491: 2D: unauthenticated remote attackers could execute
arbitrary code via multiple protocols.
* CVE-2015-0492: JavaFX: unauthenticated remote attackers could
execute arbitrary code via multiple protocols.

Security Issues:

* CVE-2015-0458
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0458>
* CVE-2015-0459
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0459>
* CVE-2015-0460
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0460>
* CVE-2015-0469
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0469>
* CVE-2015-0477
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0477>
* CVE-2015-0478
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0478>
* CVE-2015-0480
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0480>
* CVE-2015-0484
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0484>
* CVE-2015-0488
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0488>
* CVE-2015-0491
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0491>
* CVE-2015-0492
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0492>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-java-1_7_0-openjdk=10621

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64) [New Version: 1.7.0.75]:

java-1_7_0-openjdk-1.7.0.75-0.9.1
java-1_7_0-openjdk-demo-1.7.0.75-0.9.1
java-1_7_0-openjdk-devel-1.7.0.75-0.9.1


References:

https://www.suse.com/security/cve/CVE-2015-0458.html
https://www.suse.com/security/cve/CVE-2015-0459.html
https://www.suse.com/security/cve/CVE-2015-0460.html
https://www.suse.com/security/cve/CVE-2015-0469.html
https://www.suse.com/security/cve/CVE-2015-0477.html
https://www.suse.com/security/cve/CVE-2015-0478.html
https://www.suse.com/security/cve/CVE-2015-0480.html
https://www.suse.com/security/cve/CVE-2015-0484.html
https://www.suse.com/security/cve/CVE-2015-0488.html
https://www.suse.com/security/cve/CVE-2015-0491.html
https://www.suse.com/security/cve/CVE-2015-0492.html
https://bugzilla.suse.com/927591

https://download.suse.com/patch/finder/?keywords=2082b6af65787f83584579a0178ad27e

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages