Mailinglist Archive: opensuse-security-announce (21 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:0704-2: important: Security update for MozillaFirefox
SUSE Security Update: Security update for MozillaFirefox
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:0704-2
Rating: important
References: #925368
Cross-References: CVE-2015-0801 CVE-2015-0807 CVE-2015-0813
CVE-2015-0814 CVE-2015-0815 CVE-2015-0816

Affected Products:
SUSE Linux Enterprise Desktop 12
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

Mozilla Firefox was updated to 31.6.0 ESR to fix five security issues.

The following vulnerabilities were fixed:

* Miscellaneous memory safety hazards (MFSA
2015-30/CVE-2015-0814/CVE-2015-0815)
* Use-after-free when using the Fluendo MP3 GStreamer plugin (MFSA
2015-31/CVE-2015-0813)
* resource:// documents can load privileged pages (MFSA
2015-33/CVE-2015-0816)
* CORS requests should not follow 30x redirections after preflight (MFSA
2015-37/CVE-2015-0807)
* Same-origin bypass through anchor navigation (MFSA 2015-40/CVE-2015-0801)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 12:

zypper in -t patch SUSE-SLE-DESKTOP-12-2015-165=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 12 (x86_64):

MozillaFirefox-31.6.0esr-30.1
MozillaFirefox-debuginfo-31.6.0esr-30.1
MozillaFirefox-debugsource-31.6.0esr-30.1
MozillaFirefox-translations-31.6.0esr-30.1


References:

https://www.suse.com/security/cve/CVE-2015-0801.html
https://www.suse.com/security/cve/CVE-2015-0807.html
https://www.suse.com/security/cve/CVE-2015-0813.html
https://www.suse.com/security/cve/CVE-2015-0814.html
https://www.suse.com/security/cve/CVE-2015-0815.html
https://www.suse.com/security/cve/CVE-2015-0816.html
https://bugzilla.suse.com/925368

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages