Mailinglist Archive: opensuse-security-announce (36 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:1698-1: important: Security update for Linux kernel
SUSE Security Update: Security update for Linux kernel
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:1698-1
Rating: important
References: #907818 #909077 #910251
Cross-References: CVE-2014-8133 CVE-2014-9090 CVE-2014-9322

Affected Products:
SUSE Linux Enterprise Server 11 SP2 LTSS
SUSE Linux Enterprise Server 11 SP1 LTSS
SLE 11 SERVER Unsupported Extras
______________________________________________________________________________

An update that fixes three vulnerabilities is now
available. It includes two new package versions.

Description:


The SUSE Linux Enterprise 11 Service Pack 2 LTSS kernel has been updated
to fix security issues on kernels on the x86_64 architecture.

The following security bugs have been fixed:

*

CVE-2014-9322: A local privilege escalation in the x86_64 32bit
compatibility signal handling was fixed, which could have been used by
local attackers to crash the machine or execute code.

*

CVE-2014-9090: The do_double_fault function in
arch/x86/kernel/traps.c in the Linux kernel did not properly handle faults
associated with the Stack Segment (SS) segment register, which allowed
local users to cause a denial of service (panic) via a modify_ldt system
call, as demonstrated by sigreturn_32 in the 1
-clock-tests test suite.

*

CVE-2014-8133: Insufficient validation of TLS register usage could
have leaked information from the kernel stack to userspace.

Security Issues:

* CVE-2014-8133
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8133>
* CVE-2014-9090
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9090>
* CVE-2014-9322
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9322>

Indications:

Everyone using the Linux Kernel on x86_64 architecture should update.

Special Instructions and Notes:

Please reboot the system after installing this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP2 LTSS:

zypper in -t patch slessp2-kernel-10114

- SUSE Linux Enterprise Server 11 SP1 LTSS:

zypper in -t patch slessp1-kernel-10109

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP2 LTSS (x86_64) [New Version: 3.0.101]:

kernel-default-3.0.101-0.7.27.1
kernel-default-base-3.0.101-0.7.27.1
kernel-default-devel-3.0.101-0.7.27.1
kernel-ec2-3.0.101-0.7.27.1
kernel-ec2-base-3.0.101-0.7.27.1
kernel-ec2-devel-3.0.101-0.7.27.1
kernel-source-3.0.101-0.7.27.1
kernel-syms-3.0.101-0.7.27.1
kernel-trace-3.0.101-0.7.27.1
kernel-trace-base-3.0.101-0.7.27.1
kernel-trace-devel-3.0.101-0.7.27.1
kernel-xen-3.0.101-0.7.27.1
kernel-xen-base-3.0.101-0.7.27.1
kernel-xen-devel-3.0.101-0.7.27.1
xen-kmp-default-4.1.6_08_3.0.101_0.7.27-0.5.5
xen-kmp-trace-4.1.6_08_3.0.101_0.7.27-0.5.5

- SUSE Linux Enterprise Server 11 SP1 LTSS (x86_64) [New Version: 2.6.32.59]:

kernel-default-2.6.32.59-0.17.1
kernel-default-base-2.6.32.59-0.17.1
kernel-default-devel-2.6.32.59-0.17.1
kernel-ec2-2.6.32.59-0.17.1
kernel-ec2-base-2.6.32.59-0.17.1
kernel-ec2-devel-2.6.32.59-0.17.1
kernel-source-2.6.32.59-0.17.1
kernel-syms-2.6.32.59-0.17.1
kernel-trace-2.6.32.59-0.17.1
kernel-trace-base-2.6.32.59-0.17.1
kernel-trace-devel-2.6.32.59-0.17.1
kernel-xen-2.6.32.59-0.17.1
kernel-xen-base-2.6.32.59-0.17.1
kernel-xen-devel-2.6.32.59-0.17.1
xen-kmp-default-4.0.3_21548_18_2.6.32.59_0.17-0.9.2
xen-kmp-trace-4.0.3_21548_18_2.6.32.59_0.17-0.9.2

- SLE 11 SERVER Unsupported Extras (x86_64):

ext4-writeable-kmp-default-0_3.0.101_0.7.27-0.14.132
ext4-writeable-kmp-trace-0_3.0.101_0.7.27-0.14.132
ext4-writeable-kmp-xen-0_3.0.101_0.7.27-0.14.132
kernel-default-extra-2.6.32.59-0.17.1
kernel-default-extra-3.0.101-0.7.27.1
kernel-xen-extra-2.6.32.59-0.17.1
kernel-xen-extra-3.0.101-0.7.27.1


References:

http://support.novell.com/security/cve/CVE-2014-8133.html
http://support.novell.com/security/cve/CVE-2014-9090.html
http://support.novell.com/security/cve/CVE-2014-9322.html
https://bugzilla.suse.com/show_bug.cgi?id=907818
https://bugzilla.suse.com/show_bug.cgi?id=909077
https://bugzilla.suse.com/show_bug.cgi?id=910251

http://download.suse.com/patch/finder/?keywords=17cbd241265ffb7301400d4f2497c986

http://download.suse.com/patch/finder/?keywords=ea18fe4b0ce01bc702a6120012e00755

http://download.suse.com/patch/finder/?keywords=eb83dad7b182df22a0ec3ccf37ff136d

http://download.suse.com/patch/finder/?keywords=fd8795d7eb65884e7e60e637c1890c6f

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages