Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:1081-1: important: Security update for apache2
SUSE Security Update: Security update for apache2
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:1081-1
Rating: important
References: #852401 #859916 #869105 #869106 #887765 #887768

Cross-References: CVE-2013-6438 CVE-2014-0098 CVE-2014-0226
CVE-2014-0231
Affected Products:
SUSE Linux Enterprise Server 11 SP1 LTSS
______________________________________________________________________________

An update that solves four vulnerabilities and has two
fixes is now available. It includes one version update.

Description:


This apache2 update fixes the following security and non-security issues:

* mod_cgid denial of service (CVE-2014-0231, bnc#887768)
* mod_status heap-based buffer overflow (CVE-2014-0226, bnc#887765)
* mod_dav denial of service (CVE-2013-6438, bnc#869105)
* log_cookie mod_log_config.c remote denial of service (CVE-2014-0098,
bnc#869106)
* Support ECDH in Apache2 (bnc#859916)
* apache fails to start with SSL on Xen kernel at boot time
(bnc#852401)

Security Issues:

* CVE-2014-0098
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0098>
* CVE-2013-6438
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6438>
* CVE-2014-0226
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0226>
* CVE-2014-0231
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0231>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP1 LTSS:

zypper in -t patch slessp1-apache2-9619

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP1 LTSS (i586 s390x x86_64) [New Version:
2.2.12]:

apache2-2.2.12-1.48.1
apache2-doc-2.2.12-1.48.1
apache2-example-pages-2.2.12-1.48.1
apache2-prefork-2.2.12-1.48.1
apache2-utils-2.2.12-1.48.1
apache2-worker-2.2.12-1.48.1


References:

http://support.novell.com/security/cve/CVE-2013-6438.html
http://support.novell.com/security/cve/CVE-2014-0098.html
http://support.novell.com/security/cve/CVE-2014-0226.html
http://support.novell.com/security/cve/CVE-2014-0231.html
https://bugzilla.novell.com/852401
https://bugzilla.novell.com/859916
https://bugzilla.novell.com/869105
https://bugzilla.novell.com/869106
https://bugzilla.novell.com/887765
https://bugzilla.novell.com/887768

http://download.suse.com/patch/finder/?keywords=9c5ea88101bc5060dd62e74ff4f50214

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages