Mailinglist Archive: opensuse-security-announce (19 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0890-1: important: Security update for pidgin, finch and libpurple
SUSE Security Update: Security update for pidgin, finch and libpurple
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0890-1
Rating: important
References: #770304
Cross-References: CVE-2012-3374
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 10 SP4
SLE SDK 10 SP4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update of pidgin fixes a stack-based buffer overflow
in the MXit protocol which could have potentially been
exploited by remote attackers to execute arbitrary code in
the context of the user running pidgin (CVE-2012-3374).

Security Issue reference:

* CVE-2012-3374
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3374
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp1-finch-6534

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-finch-6534

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp1-finch-6534

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-finch-6534

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64
s390x x86_64):

finch-2.6.6-0.17.1
finch-devel-2.6.6-0.17.1
libpurple-2.6.6-0.17.1
libpurple-devel-2.6.6-0.17.1
libpurple-lang-2.6.6-0.17.1
pidgin-2.6.6-0.17.1
pidgin-devel-2.6.6-0.17.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

finch-2.6.6-0.17.1
finch-devel-2.6.6-0.17.1
libpurple-2.6.6-0.17.1
libpurple-devel-2.6.6-0.17.1
libpurple-lang-2.6.6-0.17.1
pidgin-2.6.6-0.17.1
pidgin-devel-2.6.6-0.17.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):

finch-2.6.6-0.17.1
libpurple-2.6.6-0.17.1
libpurple-lang-2.6.6-0.17.1
libpurple-meanwhile-2.6.6-0.17.1
libpurple-tcl-2.6.6-0.17.1
pidgin-2.6.6-0.17.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

finch-2.6.6-0.17.1
libpurple-2.6.6-0.17.1
libpurple-lang-2.6.6-0.17.1
libpurple-meanwhile-2.6.6-0.17.1
libpurple-tcl-2.6.6-0.17.1
pidgin-2.6.6-0.17.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

finch-2.6.6-0.18.1
libpurple-2.6.6-0.18.1
pidgin-2.6.6-0.18.1

- SLE SDK 10 SP4 (i586 ia64 ppc s390x x86_64):

finch-2.6.6-0.18.1
finch-devel-2.6.6-0.18.1
libpurple-2.6.6-0.18.1
libpurple-devel-2.6.6-0.18.1
pidgin-2.6.6-0.18.1
pidgin-devel-2.6.6-0.18.1


References:

http://support.novell.com/security/cve/CVE-2012-3374.html
https://bugzilla.novell.com/770304

http://download.novell.com/patch/finder/?keywords=6cdbffccfb7e818b850e497dc8f94724

http://download.novell.com/patch/finder/?keywords=a738afec13eba5d4d2ab0d2b9a6f3416

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages