Mailinglist Archive: opensuse-security-announce (14 mails)

< Previous Next >
[security-announce] openSUSE-SU-2012:0508-1: critical: update for samba
openSUSE Security Update: update for samba
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0508-1
Rating: critical
References: #752797
Cross-References: CVE-2012-1182
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Samba upgrade to version 3.6.3 fixes the following
security issue:

- PIDL based autogenerated code allows overwriting beyond
of allocated array. Remove attackers could exploit that
to execute arbitrary code as root (CVE-2012-1182,
bso#8815, bnc#752797)

Please see /usr/share/doc/packages/samba/WHATSNEW.txt from
the samba-doc package or the package change log (rpm -q
--changelog samba) for more details of the version update.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-224

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

ldapsmb-1.34b-112.1
libldb-devel-1.0.2-112.1
libldb1-1.0.2-112.1
libldb1-debuginfo-1.0.2-112.1
libnetapi-devel-3.6.3-112.1
libnetapi0-3.6.3-112.1
libnetapi0-debuginfo-3.6.3-112.1
libsmbclient-devel-3.6.3-112.1
libsmbclient0-3.6.3-112.1
libsmbclient0-debuginfo-3.6.3-112.1
libsmbsharemodes-devel-3.6.3-112.1
libsmbsharemodes0-3.6.3-112.1
libsmbsharemodes0-debuginfo-3.6.3-112.1
libtalloc-devel-2.0.5-112.1
libtalloc2-2.0.5-112.1
libtalloc2-debuginfo-2.0.5-112.1
libtdb-devel-1.2.9-112.1
libtdb1-1.2.9-112.1
libtdb1-debuginfo-1.2.9-112.1
libtevent-devel-0.9.11-112.1
libtevent0-0.9.11-112.1
libtevent0-debuginfo-0.9.11-112.1
libwbclient-devel-3.6.3-112.1
libwbclient0-3.6.3-112.1
libwbclient0-debuginfo-3.6.3-112.1
samba-3.6.3-112.1
samba-client-3.6.3-112.1
samba-client-debuginfo-3.6.3-112.1
samba-debuginfo-3.6.3-112.1
samba-debugsource-3.6.3-112.1
samba-devel-3.6.3-112.1
samba-krb-printing-3.6.3-112.1
samba-krb-printing-debuginfo-3.6.3-112.1
samba-winbind-3.6.3-112.1
samba-winbind-debuginfo-3.6.3-112.1

- openSUSE 11.4 (x86_64):

libldb1-32bit-1.0.2-112.1
libldb1-debuginfo-32bit-1.0.2-112.1
libsmbclient0-32bit-3.6.3-112.1
libsmbclient0-debuginfo-32bit-3.6.3-112.1
libtalloc2-32bit-2.0.5-112.1
libtalloc2-debuginfo-32bit-2.0.5-112.1
libtdb1-32bit-1.2.9-112.1
libtdb1-debuginfo-32bit-1.2.9-112.1
libtevent0-32bit-0.9.11-112.1
libtevent0-debuginfo-32bit-0.9.11-112.1
libwbclient0-32bit-3.6.3-112.1
libwbclient0-debuginfo-32bit-3.6.3-112.1
samba-32bit-3.6.3-112.1
samba-client-32bit-3.6.3-112.1
samba-client-debuginfo-32bit-3.6.3-112.1
samba-debuginfo-32bit-3.6.3-112.1
samba-winbind-32bit-3.6.3-112.1
samba-winbind-debuginfo-32bit-3.6.3-112.1

- openSUSE 11.4 (noarch):

samba-doc-3.6.3-112.1

- openSUSE 11.4 (ia64):

libldb1-debuginfo-x86-1.0.2-112.1
libldb1-x86-1.0.2-112.1
libsmbclient0-debuginfo-x86-3.6.3-112.1
libsmbclient0-x86-3.6.3-112.1
libtalloc2-debuginfo-x86-2.0.5-112.1
libtalloc2-x86-2.0.5-112.1
libtdb1-debuginfo-x86-1.2.9-112.1
libtdb1-x86-1.2.9-112.1
libtevent0-debuginfo-x86-0.9.11-112.1
libtevent0-x86-0.9.11-112.1
libwbclient0-debuginfo-x86-3.6.3-112.1
libwbclient0-x86-3.6.3-112.1
samba-client-debuginfo-x86-3.6.3-112.1
samba-client-x86-3.6.3-112.1
samba-debuginfo-x86-3.6.3-112.1
samba-winbind-debuginfo-x86-3.6.3-112.1
samba-winbind-x86-3.6.3-112.1
samba-x86-3.6.3-112.1


References:

http://support.novell.com/security/cve/CVE-2012-1182.html
https://bugzilla.novell.com/752797

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages